Analytics
3.8K members online now
3.8K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

GTA shows "No HTTP response detected", but visits seem to get logged

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hey there,

 
This has been bugging me for the past few days: I'm getting the "No HTTP response detected" GTA error on two PrestaShop-enabled e-commerce stores, but the visits and transactions seem to get picked up fine in Analytics (tested with "Real-Time" as well). Also, the error seems to show up only on category-type pages, not on product pages.
 
Here's an example: http://goo.gl/36SNr3
 
GA Debug reveals no errors.
 
Any suggestions? Should I just ignore the error?
 
Thanks!
1 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by Dave_Davis (Top Contributor)
November 2015

Re: GTA shows "No HTTP response detected", but visits seem t

[ Edited ]
Top Contributor
# 2
Top Contributor

Hi Mihai,

The problem is caused because of the http request limit to GA is exceeded. On your example page there are 15 products. If you reduce that to 10 the problem disappears.

http://goo.gl/YQxQxH

I'm not familiar with PrestaShop, you need to find a way to limit the product impressions on the category pages to ~10 at once to prevent this issue. Hope this helps.


Arnold Majlath, Google Analytics Top Contributor
Was my response helpful? If yes, please accept it as solution.
Circle Me On Google+ | Visit me @ Redfly Digital

View solution in original post

Marked as Best Answer.
Solution
Accepted by Dave_Davis (Top Contributor)
November 2015

Re: GTA shows "No HTTP response detected", but visits seem t

[ Edited ]
Top Contributor
# 2
Top Contributor

Hi Mihai,

The problem is caused because of the http request limit to GA is exceeded. On your example page there are 15 products. If you reduce that to 10 the problem disappears.

http://goo.gl/YQxQxH

I'm not familiar with PrestaShop, you need to find a way to limit the product impressions on the category pages to ~10 at once to prevent this issue. Hope this helps.


Arnold Majlath, Google Analytics Top Contributor
Was my response helpful? If yes, please accept it as solution.
Circle Me On Google+ | Visit me @ Redfly Digital

Re: GTA shows "No HTTP response detected", but visits seem t

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
I see. Wasn't the request limit 8192 bytes? I know that whenever I was passed that, I'd get an error in GA Debug such as

Error: type={0: "len", 1: 15112} method= message= account=

and the visits would not get logged.

However, in this case, there's no error in GA Debug, and the visits do actually get logged. Maybe GTA is doing a different calculation?

Re: GTA shows "No HTTP response detected", but visits seem t

[ Edited ]
Top Contributor
# 4
Top Contributor

Yes, the request limit is 8k. I didn't check how much data is being actually sent, GTA might be wrong about it. The problem in GTA disappears when there are fewer products on the page so it might doing a different calculation. It is known to give false alarms. If the data in GA seems all correct I guess you can ignore the GTA error. As you said GA Debug reveals no errors.


Arnold Majlath, Google Analytics Top Contributor
Was my response helpful? If yes, please accept it as solution.
Circle Me On Google+ | Visit me @ Redfly Digital

Re: GTA shows "No HTTP response detected", but visits seem t

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
Good to know, thanks!

Re: GTA shows "No HTTP response detected", but visits seem t

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭
Hi Arnold,

Is there anything I can do to improve the http request limit?