Analytics
5K members online now
5K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

During code: "URL must not contain a fragment" don't know a cure!

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭
1 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author Ken F
January 2016

Re: During code: "URL must not contain a fragment" don't kno

Top Contributor
# 8
Top Contributor

Not sure why get that. Try deleting the account recreating a new one.

When I do it, I get no problems:

 

 

Here it is with the fragment at the end, and the subsequent error, on the Account Creation page:

Screenshot - 1_20_2016 , 12_18_39 PM.png

 

 

And here it is without the fragment at the end, and here you might notice that this is on the next page when the account has been successfully created.

Screenshot - 1_20_2016 , 12_19_10 PM.png

Nicky Yuen, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | LinkedIn

View solution in original post

Re: During code: "URL must not contain a fragment" don't kno

Top Contributor
# 2
Top Contributor
Hi Ken F,

The "fragment" is another name for the "anchor" or "hash", so in the URL you linked to, the "fragment" would be the "#/" at the end.

Where are you seeing this error in GA?
Nicky Yuen, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | LinkedIn

Re: During code: "URL must not contain a fragment" don't kno

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
New AccountWhat would you like to track?WebsiteMobile appSetting up your account Account Name Accounts are the top-most level of organization and contain one or more tracking IDs. Setting up your property Website Name Website URL https:// URL must not contain a fragment Industry Category

Re: During code: "URL must not contain a fragment" don't kno

Top Contributor
# 4
Top Contributor
Hi Ken, assuming this is a copy and paste or something, but it didn't get formatted well. Can you post again as a screen shot image?
Nicky Yuen, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | LinkedIn

Re: During code: "URL must not contain a fragment" don't know

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

New Account

What would you like to track?

WebsiteMobile app

Setting up your account

Account Name
Accounts are the top-most level of organization and contain one or more tracking IDs.
 

Setting up your property

Website Name
 
Website URL
 Question: "Where's the 'fragment'? (I tried removing the hashtag, still no-go)
URL must not contain a fragment
Industry Category

Re: During code: "URL must not contain a fragment" don't kno

Top Contributor
# 6
Top Contributor
Delete the #/ at the end and it should validate.
Nicky Yuen, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | LinkedIn

Re: During code: "URL must not contain a fragment" don't kno

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭
I mentioned above: "I tried that!"
it doesn't work, and I can't leave the page to get the tagging info on the next page!

I even tried by removing the [x/] as well

Here is the entire URL, where's the fragment that the site is talking about?

(https://www.indiegogo.com/projects/coming-to-a-white-house-near-you-by-george-w-bush/x/10860179#/)
Marked as Best Answer.
Solution
Accepted by topic author Ken F
January 2016

Re: During code: "URL must not contain a fragment" don't kno

Top Contributor
# 8
Top Contributor

Not sure why get that. Try deleting the account recreating a new one.

When I do it, I get no problems:

 

 

Here it is with the fragment at the end, and the subsequent error, on the Account Creation page:

Screenshot - 1_20_2016 , 12_18_39 PM.png

 

 

And here it is without the fragment at the end, and here you might notice that this is on the next page when the account has been successfully created.

Screenshot - 1_20_2016 , 12_19_10 PM.png

Nicky Yuen, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | LinkedIn

Re: During code: "URL must not contain a fragment" don't kno

Visitor ✭ ✭ ✭
# 9
Visitor ✭ ✭ ✭
You are completely correct, and I had tried that several times, but 'nothing' the red error stayed.
You were 'right' though, only when I had followed your instruction to close, and re-open the account page.
When I re-opened, and followed what you instructed, the same 'red error, but then, disgusted with it, I clicked to the next page in defiance, guess what, the page 'reset' despite the "URL must not contain", here's why; I had cc'd the URL same as before, the red warning came on as always, 'then' I removed the fragment, but the red stayed. Apparently I should have pasted the 'corrected version' only. Once their software is triggered, you need to close the account for forgiveness from it.
Very brainy, Nick.

Thanks, Ken

During code: "URL must not contain a fragment" don't know a cure!

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭

thanks sir for your i got my id