Analytics
4.6K members online now
4.6K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

Custom Campaign URL not tracking and showing data in Analytics

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hello Google Analytics Community,

 

We recently used the Campaign URL Builder to build a custom URL to track a campaign. Since it's implementation NO data has generated under the Campaigns tab and we are having some trouble figuring out why. We copied the URL directly from the builder and implemented it and have doubled checked that the it is correct. The URL is set up as a link on our website. Has anyone experienced this problem before and how did you resolve it? Please let me know if you need more info. 

 

Thanks!

2 Expert replyverified_user

Re: Custom Campaign URL not tracking and showing data in Analytics

Rising Star
# 2
Rising Star
Hi Criterion, how are things?

There're a few things we need to cover to try and figure it out what's going on.

It would be of great help if you could provide your URL website and even and example of a coded built with the URL builder. Even when using the builder, depending on your URL architecture i can cause conflicts with the UTM parameters.

Also, make sure that your GA snippet is installed correctly. Only the "Campaigns" data are not showing, or anything else is also cleared out?

Leandro Martinez | Basta1Click

Re: Custom Campaign URL not tracking and showing data in Analytics

Top Contributor
# 3
Top Contributor
Hi Criterion
Can you paste your "built" URL here?
When you paste it into the address bar, does the visit appear in your real time analytics?
Are you seeing other campaign info? As in AdWords campaign info?
You say that the URL is set up as a link on your website, are you trying to track clicks from one part of your website to another and have it appear in the campaign reports?
Can you provide a link to where this is?

Re: Custom Campaign URL not tracking and showing data in Analytics

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭
Hello,

Here is the URL we built.

http://www.whatsyourpurpose.nyc/?utm_source=citystate&utm_medium=sponsoredcontent&utm_campaign=wypgr...

Yes we are trying to track users who click the link on our site.

Other campaigns are showing up in our reports except for this one. When you click the link it doesn't even show up in real time.

We are not doing Google Adwords.

What do you think might be causing the problem?

Thanks!

Re: Custom Campaign URL not tracking and showing data in Analytics

Top Contributor
# 5
Top Contributor
Hmmm, you've got the analytics code installed twice on your site. The old and new versions. One is sending 2 pageview requests. These could be causing a conflict.
Can you show an example of a tagged URL that IS working?
Can you confirm that you see the alternative in real time?

Re: Custom Campaign URL not tracking and showing data in Analytics

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭
Hi Dave,

We just found out that our CMS system has Google Analytics already built in. We have also been adding the code to our pages. That might be why you are seeing two scripts. Even though this has been discovered, all of our other campaigns have tracked data. This is the only campaign that is not tracking.

The other campaigns are through email and social. Here is an example of the email script we have used if this helps.

<!-- Sailthru Horizon -->
&lt;script type="text/javascript">
(function() {
function loadHorizon() {
var s = document.createElement('script');
s.type = 'text/javascript';
s.async = true;
s.src=location.protocol + '//ak.sail-horizon.com/horizon/v1.js';
var x = document.getElementsByTagName('script')[0];
x.parentNode.insertBefore(s, x);
}
loadHorizon();
var oldOnLoad = window.onload;
window.onload = function() {
if (typeof oldOnLoad === 'function') {
oldOnLoad();
}
Sailthru.setup({
domain: 'horizon.cityandstateny.com'
});
};
})();
&lt;/script&gt;

Re: Custom Campaign URL not tracking and showing data in Analytics

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭
Hello,

I sent a reply last Thursday regarding our URL tracking situation. I wanted to check in to see if you had any further feedback regarding our problem and how to solve it?

Thanks!

Re: Custom Campaign URL not tracking and showing data in Analytics

Visitor ✭ ✭ ✭
# 8
Visitor ✭ ✭ ✭
Hi leandrofm,

Our campaign tracking issue is still unresolved. You can find the information regarding our problem in this thread. Any feedback you can provide would be great. We look forward to hearing back from you.

Thanks!

Custom Campaign URL not tracking and showing data in Analytics

Visitor ✭ ✭ ✭
# 9
Visitor ✭ ✭ ✭

I'm having a same problem with my analytics too. this is the first time we're building url link from the analytics url builder. when I looked at the campaign it is empty.

 

here is the test link

https://www.rush-health.com/RHAWeb/aboutus/partnerhospitals.aspx?utm_source=eblast&utm_campaign=test...

 

Idk what's goin on.. traffic gets tracked but not this campaign..

 

thank you in advance

Custom Campaign URL not tracking and showing data in Analytics

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭

I"m having the same issue - here is my URL: http://www.motorcomusic.com/event/1396069-motoroboto-new-years-eve-party-durham/#utm_source=Facebook...

 

It shows up in Real-Time analytics but nothing registers in Campaigns.