AdWords is now Google Ads. Our new name reflects the full range of advertising options we offer across Search, Display, YouTube, and more. Learn more

Analytics
4.8K members online now
4.8K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

Bad Default URL

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi,

We are currently running 2 different micro sites microsite1.domain.com and mircosite2.domain.com (the main site is hosted on www.domain.com). On both micro sites, I am getting exactly the same message "Bad Default URL". We are using Umbraco for development.

 

I have checked the spelling, the url version http vs https (both are running on https) and if there is a trailing space

 

Here is what I have done:

  • I have created 2 separate properties on GA for both microsites
  • I have integrated Google Tag Manager (2 separate containers for the 2 separate tracking codes)

 

 

GA Property Settings:

- Default URL: microsite1.domain.com

and

- Default URL: microsite2.domain.com

 

GA View settings:

- website URL: microsite1.domain.com

and

- website URL: microsite2.domain.com

 

Did I miss anything? Why is it still giving me that error. The analytics seem to be coming in just fine and the tags are firing on all pages.

 

Can someone come to the rescue? 

 

Thank you all

Sam

1 Expert replyverified_user

Bad Default URL

Rising Star
# 2
Rising Star

Sam,

 

Where are you seeing the message?  In the Analytics Notifications?  It should give you more insight if you click details. 

 

That said, the default URL setting only powers the content reports flyouts and in-page analytics at this point - with the in page analytics report going away soon.  So it shouldn't cause any issues.

 

Best,

 

Theo Bennett

Analytics Evangelist at MoreVisibility | Contact Me
Connect on LinkedIn

Re: Bad Default URL

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hey Theo, Thanks so much for your quick feedback. Just to make sure I understand well, you're saying that this error should not be affecting my quality of reporting.

 

I am seeing the message on the analytics notification center. When I click on Details this is what I get. It is not helping at all.

Details.PNG

 

The question is why is it happening in the first place? and only on those microsites?

 

Regards,

Sam

 

 

Bad Default URL

Rising Star
# 4
Rising Star

Hey Sam,

 

Yes that's correct, it has no impact on your tracking you can just change it to google.com if you want and nothing will happen to the data you are collecting. 

 

You may being seeing this because they are not detecting your code on the default URL or if you have a typo or the wrong protocol selected.  Make sure protocol and URL are correct and use GA Debugger or Tag Assistant (both for Chrome and available in the Chrome store) to make sure your GA is functioning properly.

 

Best,

 

Theo Bennett

Analytics Evangelist at MoreVisibility | Contact Me
Connect on LinkedIn