Analytics
2.1K members online now
2.1K members online now
Dive into multiple domain (Cross/Sub) tracking, implementing Ecommerce and Enhanced Ecommerce, setting up Event tracking, and Universal Analytics code.
 
Guide Me
star_border
Reply

Bad Default URL but still getting analytics data

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

We have a single page website that we're using Google Analytics for some basic validation info, like new vs. return users. We are getting tracking data from the web page. However, we've also seen a notification that there's a bad default URL. We've checked the configuration and the URL is entered correctly. What might be causing this and how do we fix it?

Re: Bad Default URL but still getting analytics data

Participant ✭ ✭ ☆
# 2
Participant ✭ ✭ ☆
Check "Default page" option in View Settings. In most cases it should be blank.

Re: Bad Default URL but still getting analytics data

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Thanks! The Default page option is blank. While checking this, I did notice that the Property Settings didn't have a default view specified, so I've set that and it's pending verification as to whether that will fix the bad default URL message. Any other suggestions?

Re: Bad Default URL but still getting analytics data

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭
I am having the same issue. I'm getting analytics data but I am receiving this "Bad Default URL" message. I am wondering, in my case, if it is due to that fact that i'm trying to use GA on an internal company Sharepoint site. The site is able to use the tracking code fine because it is reporting custom dimensions that we are sending from the site however we keep getting this error message. Would appreciate any help from whomever might have more information on this error and what things may cause it even with having a proper url and correct reporting data.