Analytics
2.4K members online now
Discuss regaining access to Analytics accounts, restoring accounts, changing user access levels, and navigating the homepage
 
Guide Me
star_border
Reply

No data received though tracking snippet is installed properly

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi GA community. We have a WordPress blog on which the tracking snippet is apparently correctly installed in the header file but has not registered any hits in either the real-time section or the overview. The blog's address is the following: http://blog.flikli.com

 

I tried the debug version of analytics.js and it appears to be working properly. I've also checked the code with the Google Tag Assistant Chrome plugin, and everything checks out. I'm unsure why data is not being received in the GA dashboard.


Any help & insight into this would be greatly appreciated! 

1 Expert replyverified_user

Re: No data received though tracking snippet is installed properly

Top Contributor
# 2
Top Contributor
Hi Leo D,

Just some basic questions first. Are you checking the correct GA property? Have you made sure you don't have a filter set up that excludes your own visits? Are you checking in sooner than 24 hours after the hits have been made (because is usually takes up to 24 hours for the data to be processed)?
Nicky Yuen, Google Analytics Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | LinkedIn

Re: No data received though tracking snippet is installed properly

[ Edited ]
Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hey Nicky, thanks for responding. Yes, I double-checked the GA property, it's the one that corresponds to the site. As for filters, there are none currelntly set up. The tracking code has been installed for a few days now, and I've visited the site multiple times since then with no hits registered in the dashboard. Any ideas on what else could be the issue?

 

Some additional info: under Property Hit Volume in the Property Settings in Admin, it actually does show that there were hits in the last week, but in Tracking Info in the same section, I see the status "No data received in past 48 hours".

Re: No data received though tracking snippet is installed properly

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭
I can report the exact same problem here.

Re: No data received though tracking snippet is installed properly

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
Hey Arjen,

Just a follow up to this. I eventually discovered that the problem was that the blog is on a subdomain of our main site which is hosted on a different server than the main site. I was trying to use a different GA property for each (ie. one for the main site and one for the blog). I eventually solved it by using the same GA tracking property for both my main site and the WordPress blog. I now receive data from both the blog and the main site.

In order to see just the information for the blog, I created two filtered views (in addition to the one unfiltered view where the combined traffic shows...didn't want to mess anything up by filtering the previously existing view) One filtered view allows me to see only the blog traffic, and the other shows only the traffic to the main site.

Not sure if this is relevant to your case, but maybe it can point you towards a solution if you haven't already gotten to one.

No data received though tracking snippet is installed properly

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

I too am facing the same difficulty here.