Analytics
3K members online now
Discuss regaining access to Analytics accounts, restoring accounts, changing user access levels, and navigating the homepage
 
Guide Me
star_border
Reply

Invalid Schema error - due to duplicate index values?

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭
 I have a corrupted View for a Google Analytics account, and get the  "Invalid Schema" warning here when I go to Behavior - Site Content - All pages

This error started to appear after I set up Content Grouping.  I have disabled the Content Groups and edited them repeatedly, with no effect.

I do notice that of the five index slots in the Content Grouping, two have the value of '3' (seen screenshot here)  This would certainly give an invalid schema, as I suspect those index values must be unique.   I can't delete these index slots, and editing them so they are not mutually exclusive doesn't help so far.

 


I don't know if this duplicate index issue is causing the problem, but it's the only issue I can see.

So my questions are:

1. Is this likely the source of the problem, or is there another common source of an 'invalid schema' when using plain vanilla dimensions and no segments?
2. Is there anything I can do to modify these index values?
3. Is there anyone I can contact at Google Analytics to have them reset these index values in the View?

Thanks in advance for any and all help.

PS: I tried to include screenshots in the body of this message, but kept getting an error, so linked.

 

1 Expert replyverified_user

Re: Invalid Schema error - due to duplicate index values?

Top Contributor
# 2
Top Contributor
Hi Eric,

Oh , that's a tough one ... I've never come across that issue. Did you try to set different names for groupings? Are there any errors in your actual grouping definitions? Any difference if you switch off groupings?

Christoph

Re: Invalid Schema error - due to duplicate index values?

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Hey thanks for your response.

All great questions, so thoughtful that I have already tried them Smiley Wink

Different names and setups / definitions haven't made a difference.
Disabling all groups makes no difference.

I might have had two browser windows open when creating Content Groups, so duplicate index values were created. Google looks to parse the Content Groups, finds two with the same index value and chokes. This is my theory so far, not sure what the remedy is beyond a reset (if possible) on the backend by Google.

I am going to try querying directly from the Analytics API, though I suspect that may not solve the issue..

Thanks for your input, much appreciated.

Eric.