Analytics
2.9K members online now
Discuss regaining access to Analytics accounts, restoring accounts, changing user access levels, and navigating the homepage
 
Guide Me
star_border
Reply

Dynamic Website Basic Setup

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Thanks in advance for any help. I'm fairly new to GA, so this may be really simple, but I could use some support correctly setting up basic analytics for our MindBody e-comm site. 

 

MindBody is a business management/scheduling/e-comm platform. We subscribe to it and have limited management permissions, although MindBody does offer a GA integration option where it accepts the tracking code. 

 

Here's my question: Our homepage URL within MindBody is "https://clients.mindbodyonline.com/classic/ws?studioid=829XXX&stype=-98." This is clearly a problem because under Property Settings the Default URL can't contain a query. So I've entered "https://clients.mindbodyonline.com" in this field. 

 

In View Settings I did enter "ws.asp?studio=829XXX" in the Default Page field, as instructed by MindBody in their GA setup. The number is a specific identifier for our business. 

 

In a very basic sense, is this manner of entering information correct to get the data flowing? Or is there another approach here due to the dynamic nature of the overall site (and it's inclusion of queries in nearly all URLs). 

 

Thanks

Marked as Best Answer.
Solution
Accepted by topic author Ben S
July

Dynamic Website Basic Setup

Explorer ✭ ✭ ☆
# 2
Explorer ✭ ✭ ☆

This seems to be very specific to the way this company have decided to offer GA tracking, so it's hard to help you here. But for GA Home Page URL, this is more an indication to make it easier when navigating the reports. It seems to me just saying "https://clients.mindbodyonline.com/" should be sufficient. For the default page, I would try "ws.asp" (without the query string parameter). But if MindBody tells you to use "ws.asp?studio=XXXX", I hope they have tested it - so you should try it too and see what happen.

Dynamic Website Basic Setup

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Stéphane, 
 
Thanks for your reply. Now that I've had this set up for a few days, I can confirm you were correct with your suggestions above. The data is coming in, although determining how to identify pages is a challenge (the dynamic URLs..), but I'll get that sorted out. I will pull the query string portion and see if that changes (maybe simplifies) anything on the reporting side. 
 
Thanks Again

Re: Dynamic Website Basic Setup

[ Edited ]
Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

Hi @Ben S! I am facing the exact same issue you were. Would you mind sharing the settings you ended up using? I'm assuming...

Website's URL= "https://clients.mindbodyonline.com/"
Default Page = "ws.asp?studio=XXXXX"
 
I have created numerous views to try different combinations; none of them have worked. Their support was absolutely useless.
 
We entered our GA tracking ID as specified, yet I don't see our GA ID in the source code anywhere, so I'm not quite sure how it could ever work. @Stéphane Hamel, do you know if it is even possible for it to work without including our analytics tracking ID on the page? I don't see it on any mindbody sites.

Any suggestions?

Dynamic Website Basic Setup

Explorer ✭ ✭ ☆
# 5
Explorer ✭ ✭ ☆

Try installing Google Tag Assistant and see if any tag is firing. Doing a simple "View source" might not reveal the presence of the tag since they are generating it dynamically.

 

Re: Dynamic Website Basic Setup

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

Thanks for the quick response! So, that produces nothing but errors. I see the same thing on other MindBody sites as well.

 

Here is a copy of the Tag report. Our analytics code "UA-107XXXXXX-X" which again, shows nowhere.

https://drive.google.com/file/d/0BzTFNH8F1ow1ZWJHcmduWjFvcTQ/view?usp=sharing

 

Google Analytics report grabs nothing.

 

Judging by their support's knowledge and how messed up everything seems I don't think it is setup correctly. But, I have my doubts that it is broken on their end because I can't imagine they would let google analytics be broken for all of their customers. That's a pretty important feature Smiley Happy

Dynamic Website Basic Setup

Explorer ✭ ✭ ☆
# 7
Explorer ✭ ✭ ☆

Based on what Tag Assistant is recording, you are right, it's not working at all. Since the StudioID number is not visible, I can't load the page myself and debug it further. It looks like the page is missing the ga.js library - which would mean nobody is ever getting any data. If you can send me the actual page link privately I can have another look to confirm if the problem is really on their hand (it seems so).