AdWords is now Google Ads. Our new name reflects the full range of advertising options we offer across Search, Display, YouTube, and more. Learn more

Ads
1.4K members online now
1.4K members online now
Use Google Ads conversion tracking and reporting to measure your results. Have a question about Google Analytics? Post it here, on the Google Analytics Community!
Guide Me
star_border
Reply

ecomm_prodid warning message : tag missing

Follower ✭ ✭ ✭
# 1
Follower ✭ ✭ ✭

Hello

 

I'm trying to run a dynamic marketing campaign on a website using magento 1.7.0.2 and an extension called Anaraky.

 

The extension seems capable of inserting these tags on the product pages:

ecomm_prodid

ecomm_pagetype
ecomm_totalvalue

 

The Google Tag Assistant is happy with them and accepts the tags as correct.

 

However I'm getting an error from the Adwords system saying that "Your tag doesn't include the custom parameter "ecomm_prodid". The "error" pages are category and cms pages such as the home page.

 

Shouldn't adwords be able to read that a category page has a "ecomm_pagetype:'category'" tag and not expect the "ecomm_prodid" tag?. 

 

What should I do?,

1) insert the ecomm_prodid in the offending pages but with a blank value. I tried this and the Google tag Assistant indicated that it couldn't validate the product.

2) Give Adwords a few more days to crawl the site and find the tags?

 

Examples of URLs where Adwords says that it couldn't find the  ecomm_prodid tag

http://www.colybry.ch/eboutic/encastrables/lave-vaisselle-integrable-siemens-sn56n694eu.html  ( To me, All tags are fine)

 

https://www.colybry.ch/eboutic/machine-a-biere-krups-vb650810.html  (idem)

 

https://www.colybry.ch/eboutic/robot-comptact-3200xl-magimix-18331.html (idem)

 

 

 

 

1 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by Dave_Davis (Top Contributor)
September 2015

Re: ecomm_prodid warning message : tag missing

Follower ✭ ✭ ✭
# 7
Follower ✭ ✭ ✭

Hi Dave
I agree that is unusual, but it was the Google customer service who "found" this issue. Here's a transcript of their message:

 

"The tech specialists checked into your issue about the tag validation widget giving us a warning regarding not being able to find custom parameters for retail even though you've implemented it. The reason why this is, is because the widget is looking for the ecomm_prodid with the Google Analytics code, but you are passing it with the AdWords

We checked a sample URL:
https://www.colybry.ch/eboutic/index.php/catalog/product/view/id/342/s/croque-gaufre-sandwich-cuisin...

Since you are passing the parameters with the AdWords code in the source code and our system is looking for them with the Analytics code, it does not detect the parameters.

So we have two options:
1. Change the implementation to pass the custom parameters with the Analytics tag
2. Confirm you would like me to ask our Engineers to make a switch in our system so we start to look for the custom parameters with the AdWords tag. And let me know if you want it just changed for Retail or for custom business types also:"

 

I asked them for option number "2". And whatever it was they did on their end seems to work, I'm not getting the alerts anymore.

View solution in original post

Re: ecomm_prodid warning message : tag missing

Top Contributor
# 2
Top Contributor
Hi Jorge
On the category pages where ecomm_pagetype : "category" the ecomm_prodid should contain the ids of the products listed on that category page like ecomm_prodid : ['2919', '2905', '2859', '2845', '2546', '1986']

On the home page where ecomm_pagetype is home I would put an empty value for ecomm_prodid and ecomm_totalvalue.

This is what I do when I manually implement dynamic remarketing and it works. It just takes some time to be picked up.

On your product pages the tags seem ok to me, just set the home value to empty and wait and let me know how that goes.

Re: ecomm_prodid warning message : tag missing

Follower ✭ ✭ ✭
# 3
Follower ✭ ✭ ✭
Hi Dave

Thank you for your response.

Sorry for asking the obvious but, does there need to be a "space between the delimiter comma and the item on a list? in other words: if instead of writing
ecomm_prodid : ['2919', '2905', '2859', '2845', '2546', '1986']

I write
ecomm_prodid : ['2919','2905','2859','2845','2546','1986']

will google consider the later a bad code implementation and therefor ignore it?

J

Re: ecomm_prodid warning message : tag missing

SMG Badged Google Partner
Badged Google Partner
# 4
SMG Badged Google Partner
Badged Google Partner
Hello, did you find a solution? I am running into the same issue on my website where the Tag Assistant finds the tags, but it is not detected in Adwords. Thanks!

Re: ecomm_prodid warning message : tag missing

Follower ✭ ✭ ✭
# 5
Follower ✭ ✭ ✭
Hello Sheara

Apparently the issue lies in the fact that the client used an analytics remarketing tag on the site, which adwords didn't recognize. Last week I talked to the Google Help Line people and apparently they will be able to solve the problem by doing something on their servers so that Adwords recognizes the analytics remarketing tag. But I'm still getting the alert, so this obviously takes some time.

Hope this helps

J

Re: ecomm_prodid warning message : tag missing

Top Contributor
# 6
Top Contributor
Hi Jorge.
Thanks for the follow up. This seems really unusual. Would you be able to provide more details on how you came to the conclusion that it was a third party remarketing tag causing the issue?

I'm trying to out together a checklist for this particular problem as it's becoming a common one so I'd like to have as many potential solutions to look at as possible.

It's quite rare that we get a follow up like this from anyone so I really cannot tell you how much it is appreciated.
Marked as Best Answer.
Solution
Accepted by Dave_Davis (Top Contributor)
September 2015

Re: ecomm_prodid warning message : tag missing

Follower ✭ ✭ ✭
# 7
Follower ✭ ✭ ✭

Hi Dave
I agree that is unusual, but it was the Google customer service who "found" this issue. Here's a transcript of their message:

 

"The tech specialists checked into your issue about the tag validation widget giving us a warning regarding not being able to find custom parameters for retail even though you've implemented it. The reason why this is, is because the widget is looking for the ecomm_prodid with the Google Analytics code, but you are passing it with the AdWords

We checked a sample URL:
https://www.colybry.ch/eboutic/index.php/catalog/product/view/id/342/s/croque-gaufre-sandwich-cuisin...

Since you are passing the parameters with the AdWords code in the source code and our system is looking for them with the Analytics code, it does not detect the parameters.

So we have two options:
1. Change the implementation to pass the custom parameters with the Analytics tag
2. Confirm you would like me to ask our Engineers to make a switch in our system so we start to look for the custom parameters with the AdWords tag. And let me know if you want it just changed for Retail or for custom business types also:"

 

I asked them for option number "2". And whatever it was they did on their end seems to work, I'm not getting the alerts anymore.

Re: ecomm_prodid warning message : tag missing

Top Contributor
# 8
Top Contributor
Only getting around to thanking you now. Thanks so much for taking the time to come back with the answer. I, and I'm sure future people with the same problem, are very grateful.

Re: ecomm_prodid warning message : tag missing

Follower ✭ ✭ ✭
# 9
Follower ✭ ✭ ✭
Hi Dave

You're most welcome!

By the way if ever you make public the troubleshooting checklist you mentioned above, could you post / send me the link, please?.

Cheers

J

Re: ecomm_prodid warning message : tag missing

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭
Hi Jorge,

We're actually facing the same issue with yours. The tag assistant is happy with the code implementation on http://www.ottencoffee.co.id/coffee/ ,but Analytics haven't reported any ecomm_prodid from our site. I contacted the Adwords Customer Service yesterday, but haven't got any reply yet.

Can you share us which Customer Service department you're asking for this issue or how we fix this ourselves ? Thanks