My Business
2.5K members online now
2.5K members online now
Take your business to the next level.
Guide Me
star_border
Reply

Wrong organization is appearing in our Knowledge Graph

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi, I work for Frankford Friends School in Philadelphia, PA. When someone googles Frankford Friends School, the Knowledge Graph shows the name, and wikipedia info on, Frankford Friends Meeting House (several blocks away from us, no connection to our school). It shows our address, phone number, and website, but their name and wikipedia listing. Our Google My Business listing is verified and has been for some time.

Google+ listing:

https://business.google.com/b/114806475007192655017/dashboard/l/14091883216414426155

 

I asked for the name to be changed several weeks ago, but nothing's happened. Help! It's admissions season and lots of people are googling us!

-Amy O'Leary, Director of Development & Communications

Frankford Friends School

1500 Orthodox Street, Philadelphia, PA 19124

215-533-5368 x120

 

1 Expert replyverified_user

Re: Wrong organization is appearing in our Knowledge Graph

Top Contributor
# 2
Top Contributor
Hi Amy,

Looks like the WIKIpedia article is overriding the local listing business name - https://plus.google.com/114806475007192655017/about

How did you ask for the name to be changed so far?
Colan Nielsen, Google My Business Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | Twitter
VP, Local Search at Sterling Sky

Re: Wrong organization is appearing in our Knowledge Graph

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
I asked for the name change through "suggest an edit" on the knowledge graph. Do you know why or how the Wikipedia article is overriding the local listing business name? Or why a Wikipedia article that has nothing to do with our school would do that? It doesn't even have a link to our school.
Marked as Best Answer.
Solution
Accepted by topic author Amy O
February 2016

Re: Wrong organization is appearing in our Knowledge Graph

Top Contributor
# 4
Top Contributor
Google got back and let me know that this should be fixed. It may take up to 24 hours to show properly in search.

Circle back if it's not fixed by early next week.
Colan Nielsen, Google My Business Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | Twitter
VP, Local Search at Sterling Sky

Re: Wrong organization is appearing in our Knowledge Graph

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
Thank you so much! I will keep checking.
Amy

Re: Wrong organization is appearing in our Knowledge Graph

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭
Hi Colan, it's fixed! It's using an old terrible photo randomly pulled from the web (a local news site), but the name and website are correct.

I don't understand why our Google plus page doesn't come up during a search, or why it doesn't pull the photos from there? In any case, thank you so much for your assistance!

Re: Wrong organization is appearing in our Knowledge Graph

Top Contributor
# 7
Top Contributor
In the photos section of your dashboard you can select a primary/preferred photo. Let me know if you can find it.
Colan Nielsen, Google My Business Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | Twitter
VP, Local Search at Sterling Sky

Re: Wrong organization is appearing in our Knowledge Graph

Visitor ✭ ✭ ✭
# 8
Visitor ✭ ✭ ✭
I see Profile Photos and Business Photos. It's not pulling any of those. I don't see primary/preferred photo anywhere.

Re: Wrong organization is appearing in our Knowledge Graph

Top Contributor
# 9
Top Contributor

It's kind of hidden..

 

gmb photos 1.png

Colan Nielsen, Google My Business Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.
Find me on: Google+ | Twitter
VP, Local Search at Sterling Sky

Re: Wrong organization is appearing in our Knowledge Graph

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭
Our Profile, Logo, and Cover photos are correct and "Profile" is set as the "show first" photo. (It was already like that.) It's not pulling any of them.