AdWords is now Google Ads. Our new name reflects the full range of advertising options we offer across Search, Display, YouTube, and more. Learn more

My Business
2.5K members online now
2.5K members online now
Take your business to the next level.
Guide Me
star_border
Reply

Structured data not returning correctly - social media profiles missing from business profile

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I'm trying to get my social media profiles to show up on my business profile when one google's my business.

 

If I run the following code through the Structured Data Testing Tool

{
"@context": "http://schema.org",
"@type": "Organization",
"name": "Streissguth Gardens",
"url": "https://www.streissguthgardens.com",
"sameAs": ["http://www.facebook.com/streissguthgardens",
"http://www.instagram.com/streissguthgardens"]
}

everything is ok, however, when I add this code to my website the structured data testing tool returns the following error:

JSON-LD
Syntax error: value, object or array expected.

and the ] in my code is replaced by a comma.

 

I'm suck, and don't know how to fix this.

 

Thanks

Ben Streissguth

Streissguth Gardens

1640 Broadway E, Seattle, WA 98102

www.streissguthgardens.com

1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author Ben S
June 2017

Structured data not returning correctly - social media profiles missing from business profile

Participant ✭ ✭ ☆
# 2
Participant ✭ ✭ ☆

Hi Ben, 

I think your mistake is that you have the Schema on the site twice, once in the header (correctly) and once in the footer, with the missing ] and extra comma. Just delete the schema block in the footer, that should fix the problem. My guess is when you were trying to fix it, you were just looking at the top one, and didn't notice the broken one was down below. 

Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.

View solution in original post

Marked as Best Answer.
Solution
Accepted by topic author Ben S
June 2017

Structured data not returning correctly - social media profiles missing from business profile

Participant ✭ ✭ ☆
# 2
Participant ✭ ✭ ☆

Hi Ben, 

I think your mistake is that you have the Schema on the site twice, once in the header (correctly) and once in the footer, with the missing ] and extra comma. Just delete the schema block in the footer, that should fix the problem. My guess is when you were trying to fix it, you were just looking at the top one, and didn't notice the broken one was down below. 

Was my response helpful? If yes, please mark it as the ‘Best Answer.’ Learn how here.

Structured data not returning correctly - social media profiles missing from business profile

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Thanks James!

I have no idea how that second piece got there. :)