Data Studio
1.9K members online now
1.9K members online now
Ask questions about Data Studio
Guide Me
star_border
Reply

"No Data" after Date Range added

PYB
Visitor ✭ ✭ ✭
# 1
PYB
Visitor ✭ ✭ ✭

Hi,

     I've been trying to add a date range filter to my report. From what I've seen online, including the tutorial video, this should be a piece of cake. However, every time I try to add one to my report my chart and geo map say "no data". I've tried using multiple different preset date ranges like last 7 days, last month, last week, today, etc... The only time I get the data back is when I set it to "no date range" or "all date range." 

     I've checked and there aren't any other date filters in my report. Even changing the default date range to anything but "auto" and the above-mentioned ranges leads to the chart and geo map saying "no data." I have other filters for columns in my data so I know I'm creating it properly. I've also checked the date format and it's one of the accepted types. I've tried refreshing the data, closing and opening the report and the results are always the same.

     Does anyone have an idea how to resolve this issue? I'm I missing something ridiculously simple or is this a bug?

1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author PYB
July

"No Data" after Date Range added

Visitor ✭ ✭ ✭
# 17
Visitor ✭ ✭ ✭

Hi @PYB,

I've just finished struggling with a similar issue.

In my data set the data was not in a1:...

it was in the middle of the page, after copy it to another sheet and rearranging it works. Both date format works the same @Robert

By the way, if we're already here..

is there a way to do a calculated metric using more than 1 data source? like tableau blending?

Thanks!

 

View solution in original post

"No Data" after Date Range added

Participant ✭ ✭ ☆
# 2
Participant ✭ ✭ ☆

Is your datasource GA or google sheets? Sometimes with sheets, the dates are super finicky. Could you describe how your dates are set up?

Re:

[ Edited ]
PYB
Visitor ✭ ✭ ✭
# 3
PYB
Visitor ✭ ✭ ✭

Hi,
It's in Google sheets. The dates are set up in the format YYYY-MM-DD.
All the dates are currently from the previous 2 weeks. Some date values
repeat for multiple same-day instances which I thought might be the issue
but even with only wholly different dates the filter still makes everything
come up as "no data".

Re: Re:

Participant ✭ ✭ ☆
# 4
Participant ✭ ✭ ☆

Ok, when you edit the datasource in Data Studio (pencil), is your date set to YYYYMMDD? Sometimes it default to text or something strange like that. If that is set to text, take a look at your chart setup and make sure the date range dimension is selected along with your data source. Without that, line charts and comparisons often struggle. 

 

Date range dimension.JPG

Re: Re:

[ Edited ]
PYB
Visitor ✭ ✭ ✭
# 5
PYB
Visitor ✭ ✭ ✭

The date is set to YYYYMMDD. I've played around with the chart set-up a
bunch but to no avail. I've tried starting the report from scratch and it
still isn't working.

"No Data" after Date Range added

Participant ✭ ✭ ☆
# 6
Participant ✭ ✭ ☆

Can you provide a screenshot of your chart setup and your datasource setup?

"No Data" after Date Range added

Participant ✭ ✭ ☆
# 7
Participant ✭ ✭ ☆

I don't see a screenshot added. I find copy/paste generally doesn't work, just saving the file and loading it through the full reply editor.

Re: "No Data" after Date Range added

PYB
Visitor ✭ ✭ ✭
# 8
PYB
Visitor ✭ ✭ ✭

Sorry about that. Here they are.Chart-NoDateFilter.pngChart with no date filterChart-WithDateFilter.pngAs soon as I choose a date rangeDatasource.pngDatasource

"No Data" after Date Range added

PYB
Visitor ✭ ✭ ✭
# 9
PYB
Visitor ✭ ✭ ✭

I have found a temporary, less efficient, solution by creating a filter for "Date of Evaluation". Since it's my date dimension it filters fine but it lacks the utility of the calendar, and preset time period options. I'd still like to get the date filter working.

"No Data" after Date Range added

Participant ✭ ✭ ☆
# 10
Participant ✭ ✭ ☆

Yay for a temporary solution!

 

I was hoping to see a screenshot of the setup in DS of your chart and the dataset (the pencil menu). I'm wondering if there might be something that can be tweaked there?