Data Studio
4.9K members online now
4.9K members online now
Ask questions about Data Studio
Guide Me
star_border
Reply

Table showing "invalid dimension" and "invalid metric" but still working

Follower ✭ ✭ ☆
# 1
Follower ✭ ✭ ☆

Hi,

I have tables and charts in a dashboard, the dashboard works fine for a while, then upon revisiting it i see every chart has the following type of issue:

Capture.PNG

 

The dashboard appears to function, but it makes editing existing charts quite frustrating, is this a known issue? what's the cause?

Table showing "invalid dimension" and "invalid metric" but still working

Explorer ✭ ✭ ✭
# 2
Explorer ✭ ✭ ✭

Typically see this when replacing a datasource or a live connection to a source gets edited/updated and the linking to dimension/metrics breaks for any reason.

 

What is your datasource and has it changed recently?

Table showing "invalid dimension" and "invalid metric" but still working

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Did you change the data source?

Try to have a look if you still get option as dimension and metrics or are empty.

 

We had a lot of times this issue when copying and pasting the same report and updating the sources, especially if we created some custom metrics/dimensions.

 

Table showing "invalid dimension" and "invalid metric" but still working

Follower ✭ ✭ ☆
# 4
Follower ✭ ✭ ☆

Yes, I added some calculated fields. Does this mean that each time I add a calculated field, all my reports using that connection will all display this error?

Table showing "invalid dimension" and "invalid metric" but still working

Explorer ✭ ✭ ✭
# 5
Explorer ✭ ✭ ✭

Is your data source a Google Sheet?  And if so did you add the new calculated fields after the last column?

Table showing "invalid dimension" and "invalid metric" but still working

Follower ✭ ✭ ☆
# 6
Follower ✭ ✭ ☆

This is a Google Analytics data source, I've created the calculated fields following this guide: https://support.google.com/datastudio/answer/6299685?hl=en

Table showing "invalid dimension" and "invalid metric" but still working

Explorer ✭ ✭ ✭
# 7
Explorer ✭ ✭ ✭

I see....this should not have broken your connection to GA.  I suggest creating a brand new connection to the same GA source and see if that helps, helped a guy yesterday: 

 

https://www.en.advertisercommunity.com/t5/Data-Studio/Why-does-my-data-source-say-quot-Untitled-Data...

Re: Table showing "invalid dimension" and "invalid metric" but s

Follower ✭ ✭ ☆
# 8
Follower ✭ ✭ ☆

I'm at a bit of a loss now. This is happening on numerous reports. I have taken one of the reports and copied it, refreshed the data source, removed the data source entirely and re-added it, and it still shows as "invalid metric" and "invalid dimension" when viewing chat data.


The report still works fine, so clearly this hasn't broken the connection, but I would like to understand what has caused it.

Does anyone from google feel like taking a look? This is what appears in the menu when you click on the invalid dimension:

invalid dimension.PNG

I get the same with the invalid metric. I can re-define the metrics and dimensions, but then when the report is next viewed it shows them all as invalid again.