Data Studio
2K members online now
2K members online now
Ask questions about Data Studio
Guide Me
star_border
Reply

Segmentation filter conditions not working correctly

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

When creating a filter with multiple clauses I've run into several instances when all of a sudden the OR clause no longer works. See screenshot below. This happens specifically when I filter Pages or Landing Pages. Setting the condition to "Contains" or "Equals" does not change the result. The Data Studio documentation makes it sound like "a single filter can have a maximum of 10 OR clauses" (https://support.google.com/datastudio/answer/6291066?hl=en&ref_topic=7327560&authuser=0)

 

Screen Shot 2017-06-21 at 1.09.56 PM.png

Segmentation filter conditions not working correctly

Explorer ✭ ✭ ✭
# 2
Explorer ✭ ✭ ✭

The Contains clause isn't catching your URLs.

 

What I suggest is using RegExp Match and do the following for each exclusion:

 

\/account\-manager

 

\/senior\-copywriter

 

\/project\-traffic\-manager

Re: Segmentation filter conditions not working correctly

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

That still doesn't seem to fix my issue. See screenshot below with applied suggestion.

Screen Shot 2017-06-21 at 2.51.03 PM.png

Segmentation filter conditions not working correctly

Explorer ✭ ✭ ✭
# 4
Explorer ✭ ✭ ✭

Very strange.  You can try double escpaing the forward / such as:  \\/account\-manager ...but I don't think you have to do this anymore.

 

Also to confirm, the Data Source for your filter and the table are both "Olive & Company (M..."

Segmentation filter conditions not working correctly

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

Correct, they are both "Olive & Company (M..."

Segmentation filter conditions not working correctly

Explorer ✭ ✭ ✭
# 6
Explorer ✭ ✭ ✭

You can try double escpaing the forward / such as:  \\/account\-manager

 

Other than this I'm not sure what's causing your issue.