Data Studio
2.7K members online now
2.7K members online now
Ask questions about Data Studio
Guide Me
star_border
Reply

Scorecard shows No Data

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭
Hi Team,

We have been using Google data studio extensively since last couple of months; but suddenly we are facing issue in below report -
https://datastudio.google.com/#/org//reporting/0BxHyFhwi5y3bdnBOS043SWczZjQ/page/vRbC/edit

The data source used for this report is -
https://docs.google.com/spreadsheets/d/17owSXlWpgiujCyOvXfE9Bk-Q1JB0Bc9j2cZB5uFEblI/edit#gid=1719262...

In report, it is not fetching any numbers and showing "No data" in each graph/scorecard etc.

kindly help us solving the issue

it Scorecard shows No Data

[ Edited ]
Follower ✭ ✭ ☆
# 2
Follower ✭ ✭ ☆

How many score cards have you added in your report ? If you have more than 20 score cards in your report, chances are you will get an error. 

If the data that you are trying to access takes more than a minute to load and fetch it in the report, you will face "No Data" Errors. 

 

What makes it more difficult is the fact that these error codes are different each time you get it. And, there is no documentation available for these codes. 

 

The only way out is either to change the view of your report or to transform your source table to a simpler version i.e specific to your report. Hope this helps

Scorecard shows No Data

Participant ✭ ✭ ☆
# 3
Participant ✭ ✭ ☆

I can't view the report without being granted access. Can you provide a screen shot? The first things I'd check would be the date ranges and filters to make sure there's nothing throwing it off.

 

I've added up to  50 scorecards to a report before maxing out, though it does slow everything down. 

Scorecard shows No Data

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

I have the same problem. For one of our data sources I can't create any score cards - for any metric of this data source the scorecard just shows "No data". 
Normally I was able to fix errors like this by changing the aggregation of the metric to "Sum". But this isn't working in this case. 
Any ideas? 

Thanks in advance! Best regards, Anna

Scorecard shows No Data

Participant ✭ ✭ ☆
# 5
Participant ✭ ✭ ☆

Anna, can you provide more details? Do you have any filters on your scorecard? How are your metrics set up in DS? 

Scorecard shows No Data

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

Hi Litmon, 

thank you for the fast reply! I had no filter on the scorecard. Some metrics were numbers, others currency in € - some aggregated in Sum others in Average. None worked. 

I've now removed the data sourced and added it again as a new one. Now it alle works. Smiley Happy Maybe the data source was "broken" because I renamed some metrics directly in the Data Studio. 
Best regards, Anna