Data Studio
4.5K members online now
4.5K members online now
Ask questions about Data Studio
Guide Me
star_border
Reply

Issue with Google Analytics segments in Data Studio

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hello!

 

I have a report that recently started throwing up strange errors (see picture). I did some playing around and figured out that even though I'm connected to a Google Analytics data source using owner credentials when someone with the link but no access to the GA account views the report they can't see any widget with a custom segment applied. Is this intentional or a bug or just a feature not available yet? Or something else? I know this feature is very new(and awesome!).Screen Shot 2017-03-13 at 1.45.41 PM (002).png

 

 

 

1 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author Chris M
June

Issue with Google Analytics segments in Data Studio

Google Employee
# 4
Google Employee

Thanks for reporting this!

 

We've isolated the problem and should have a fix deployed soon. 

 

In the meantime, you can fix this yourself by editing the report and adding a new chart, which you can then delete if you don't need it.

 

(The problem occurs when you apply a report-level segment, and then don't add any page level data components. Adding a component, like a chart or a control, will cause the report-level segment to be applied correctly.)

 

Sorry for any inconvenience!

 

Best,

 

Rick

View solution in original post

Issue with Google Analytics segments in Data Studio

Visitor ✭ ✭ ✭
# 2
Visitor ✭ ✭ ✭

I'm also posting about this issue here: https://www.en.advertisercommunity.com/t5/Data-Studio/Data-Studio-Potential-Bug-Google-Analytics-seg...

 

Haven't received any responses as of yet.

Issue with Google Analytics segments in Data Studio

Explorer ✭ ✭ ☆
# 3
Explorer ✭ ✭ ☆

Have you refreshed your data source and your data in your report? Sometimes it solves many bugs. 

Marked as Best Answer.
Solution
Accepted by topic author Chris M
June

Issue with Google Analytics segments in Data Studio

Google Employee
# 4
Google Employee

Thanks for reporting this!

 

We've isolated the problem and should have a fix deployed soon. 

 

In the meantime, you can fix this yourself by editing the report and adding a new chart, which you can then delete if you don't need it.

 

(The problem occurs when you apply a report-level segment, and then don't add any page level data components. Adding a component, like a chart or a control, will cause the report-level segment to be applied correctly.)

 

Sorry for any inconvenience!

 

Best,

 

Rick