Data Studio
3K members online now
3K members online now
Ask questions about Data Studio
Guide Me
star_border
Reply

Internal site search terms not appearing in Datastudio

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I've built out a report in Datastudio to match an old dashboard view in GA for easier sharing with my team. I'm running into a problem: I have an internal site search table that shows terms searched within our site on the dashboard, but when I try to create the corresponding table in Datastudio, it shows no data. I can go into GA for the same dataset and timeframe and see the data right there - many search terms on internal search, but the Datastudio table just says "no data."

 

Is there something I need to do int he back end to get this data to populate? Thanks!

2 Expert replyverified_user

Re: Internal site search terms not appearing in Datastudio

Google Employee
# 2
Google Employee
Hi Jenn,

Can you tell me the specific dimensions/metrics you're using?

(I have a dashboard that shows search terms executed on the Data Studio Help Center, and it seems to work fine -- folks this week seem to want to know how to print a report ;-) )

Re: Internal site search terms not appearing in Datastudio

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Hi Rick,

Sorry for the massive delay in responding here.

I'm using "search term" under internal search as the dimension, and sessions as the metrics. This seemed intuitive, as that's how it's set up in my standard Google Analytics dashboard, but it just says "no data" in my table.

Thanks for your help!

Re: Internal site search terms not appearing in Datastudio

Top Contributor
# 4
Top Contributor
Hi Jenn - have you tried using it with a internal search related metric such as:
https://developers.google.com/analytics/devguides/reporting/core/dimsmets#view=detail&group=internal...

Hope it helps.

Kind regards,
Zorin
Web analyst @ escapestudio.net

Re: Internal site search terms not appearing in Datastudio

Follower ✭ ✭ ☆
# 5
Follower ✭ ✭ ☆
Jenn -- Can you confirm that you have set the Admin settings to allow your view to report on Internal Search?