Data Studio
1.5K members online now
1.5K members online now
Ask questions about Data Studio
Guide Me
star_border
Reply

Data source doesn't import correctly using Google Sheets GOOGLEFINANCE formula

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi,

 

I'm using a Google sheet to currently track all of my investment trades and am trying to make a dashboard with Data Studio. I'm using the GOOGLEFINANCE formula in the sheet as there's no way to get stock data from within DS.

 

The issue I'm having is that all cells that are using GOOGLEFINANCE show as 0 in a DS table/graph or any other component of the dashboard. I think this is a bug, but maybe someone can give me some advice on what to do?

 

Some extra information about what I'm trying to display on my dashboard:

  • Return on Investment over time
  • Current returns/ROI in a Scorecard

 

Thanks,

Josh

Data source doesn't import correctly using Google Sheets GOOGLEFINANCE formula

Explorer ✭ ✭ ✭
# 2
Explorer ✭ ✭ ✭

Have you checked the number formats and/or aggregation settings?

If any numbers contain special characters, DS may have imported the columns as dimensions instead of methics. Or they could be metrics, but the number format needs to be changed from "none" to "sum" (or something else)

Data source doesn't import correctly using Google Sheets GOOGLEFINANCE formula

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Yeah I checked my number formats and aggregation should be correct (tried a few different ones like sum and average). I think the issue may have something to do with, when I open the Google Sheet it takes up to 5 seconds for the data to populate because of the GOOGLEFINANCE call, so maybe DS is grabbing the data before it's loaded properly?

Data source doesn't import correctly using Google Sheets GOOGLEFINANCE formula

Explorer ✭ ✭ ✭
# 4
Explorer ✭ ✭ ✭

Have you tried manually refreshing the data source?

And are you using a Date column and/or date range filter widget in Data Studio?

If you are using Dates, you may need to make sure that column is recognized as Date format and added as the default column in the date range filter settings. 

 

If those things do not work, you may be correct about the lag. 

 

You could also try connecting your Sheet(s) with Bigquery and then using Bigquery as the data source instead of Sheets.