Data Studio
2.3K members online now
2.3K members online now
Ask questions about Data Studio
Guide Me
star_border
Reply

Data Studio, issue with metrics and dimensions

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi,

I create a table with the dimension Product and Country  and the metric users. I was able to see for example which products were the most searched in Spain. Now, when I select a country,  no data is available.

 

I didn´t modify nothing. Any help will be useful.

 

regards

Data Studio, issue with metrics and dimensions

Follower ✭ ✭ ✭
# 2
Follower ✭ ✭ ✭

Hi Asier,

 

You select a country via a filter?

 

Was there a date range applied to it? If yes, could be due to the fact that the previous records are outside the date range.

Re: Data Studio, issue with metrics and dimensions

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Thank you for your answer.

Yes, I selected a country and a city filter. Days ago it worked perfectly.

Yes, i chose february because records before november are outside the date
range, but not after.
if you have any idea, I will be waiting for your response.

Regards.
Marked as Best Answer.
Solution
Accepted by topic author Asier A
March 2017

Data Studio, issue with metrics and dimensions

Follower ✭ ✭ ✭
# 4
Follower ✭ ✭ ✭

 

Hi,

 

I've not encountered something similar..

 

I would suggest that you check all the widgets' data range and filters as well as all filters on the report.

 

Any filters on other pages? If those filter are marked as report-level they will affect other pages too.

 

If after all these you still cannot identify the issue. Maybe you can create a new report with just the table and see what is the data showing. If is the same as your existing report, then at least you know your report is fine and can focus on the data source.

 

if you are using any calculated fields, do check them as well. If google change the variable name it would break your code.

 

Hope you can find the issue soon.

Data Studio, issue with metrics and dimensions

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

Hi,

 

It must be that!

 

There are new filters on analytics. 2 weeks ago the table worked and since last week doesn´t. Just after the filters were created.

I will check it and hopefully we can find a solution.

Thank you very much