Data Studio
5K members online now
5K members online now
Ask questions about Data Studio
Guide Me
star_border
Reply

[Data Studio] Google Analytics not connecting

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I'm trying to set up a Google Analytics Dashboard in Data Studio. I go through the process of connecting the data source, and everything is fine. I click "Add to Report". But when I try to add elements to the report, even though the data source is connected, I get that I have only invalid dimensions and metrics. When I go to edit the data source, instead of the fields, I get a screen with fields for "Authorization Scope URL" and "Enter Customized Proto". I can't find any information on what that is. I've logged into multiple accounts, restarted my computer, cleared cookies, used templated reports that I know are configured properly, tried many different GA views, and it's always the same thing. I don't have too many reports. 

 

Thoughts? 

 

Marissa

2 Expert replyverified_user

[Data Studio] Google Analytics not connecting

Visitor ✭ ✭ ✭
# 2
Visitor ✭ ✭ ✭

Update - the issue was only in Chrome, but I could get it to work in IE. 

[Data Studio] Google Analytics not connecting

Google Employee
# 3
Google Employee

Hi Marissa, 

 

Can you share edit access to the report with data-studio-help@google.com and we'll take a look?

 

Thanks!

 

 

[Data Studio] Google Analytics not connecting

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

I sent it on. 

[Data Studio] Google Analytics not connecting

Google Employee
# 5
Google Employee

Can you also share the data source you're using? You can do this by navigating to the home screen, clicking on data sources on the left nav, and then clicking on the 3 vertical dots next to the data source and clicking share.

 

Thank!

[Data Studio] Google Analytics not connecting

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

I'm having a similar issue. I go to connect a data source but it won't give me the option to connect to or add to report?

 

[Data Studio] Google Analytics not connecting

Google Employee
# 7
Google Employee

Hi Marissa,

 

Did you just click connect from the data source? We're trying to reproduce how you got into this state. Does creating a new data source cause the same problem?

[Data Studio] Google Analytics not connecting

Visitor ✭ ✭ ✭
# 8
Visitor ✭ ✭ ✭

I tried it several different ways, but here is one of the processes: 

 

1. I go to the Data Sources Page;

2. I click the big blue button to add a new data source;

3. I click Google Analytics and go through the process of creating a GA data source; 

4. I click "Add to Report"

5. The report is automatically created, and I click "Add to Report" in the add to report pop up.

6. When I attempt to add any element to the report (a timeline, a scorecard, anything), while the data source appears as the data source, I have only "invalid" as a choice under metrics and/or dimensions.

7. When I go to edit the data source to see what is happening, I get a screen this screen

 

A few things to note: 

* This is only an issue in Chrome. I went through this process in Internet Explorer, and did not have the same issue; 

* This is only an issue for GA data. When I did the same thing for Google Sheets data, I had no issue; 

 

At this point, all I can think of is that I have a Chrome plugin that is not playing nicely. I will de-activate some and see what happens. If you have other thoughts, I'd love to hear them. 

 

Marissa

 

[Data Studio] Google Analytics not connecting

[ Edited ]
Visitor ✭ ✭ ✭
# 9
Visitor ✭ ✭ ✭

I can confirm the same issue affecting me using Chrome, cannot set up any new data sources to Google Analytics.

 

However I also cannot get Data Studio to work at all in IE.

[Data Studio] Google Analytics not connecting

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭

Good news, it works fine in Microsoft Edge, MS to the rescue (you have no idea how painful that is to say).