Data Studio
5.9K members online now
5.9K members online now
Ask questions about Data Studio
Guide Me
star_border
Reply

Data Sources in Data Studio Disconnect

Explorer ✭ ✭ ✭
# 1
Explorer ✭ ✭ ✭

The Data Source(s) seem to disconnect every time I make an adjustment to Dimensions or Metrics, and even if I click on a chart option like adjusting a filter or sorting a column. 

 

This issue has per sister across every sample report, every custom report and different data sources. I've tried Adwords, Analytics, Sheets, and Sample Data Sets in addition to  deleting all reports, deleting all data sources,  and re-starting everything from scratch. Nothing seems to fix the problem, however, except for deleting and re-adding data sources. This "fix" only works until the next edit though, and sometimes I have to refresh the entire page just to get data sources to show up, so it's not really much of a fix.

 

This problem has lasted for almost a full week now without fail. The first hour or two that I spent messing around in Data Studio seemed to work fine, then the error started popping up out of nowhere and never went away. The error looks like a triangle with "!" And says something like "server error..." with a greyed out chart(s). Sometimes it's a couple charts and sometimes it's all charts. 

 

Google vaguely mentions this error in their documentation and they state that the removal and re-connection of a data source may fix it. This makes me think that this bug is not unique and that Google is aware of it but I cannot seem to find any other information about this. 

 

Does anyone here know if or how this can be fixed?!

 

Thanks. 

 

 

2 Expert replyverified_user

Re: Data Sources in Data Studio Disconnect

Google Employee
# 2
Google Employee
Hi Ad,

Sorry you're having these issues!

Can you tell me specifically what you mean by making "an adjustment to Dimensions or Metrics"? Are you editing the data source, or the underlying data set (e.g. making a change to the BigQuery table schema, or the Google Sheets column structure?

And are you saying that when you select a filter control option or sort a table in VIEW mode, things break? Or are you changing the filter PROPERTY and reordering the columns in a table in EDIT mode?

Any specific steps you can provide might help me figure out what's going on.

Thanks!

Rick

Re: Data Sources in Data Studio Disconnect

Explorer ✭ ✭ ✭
# 3
Explorer ✭ ✭ ✭
Anything I do at all will basically cause the data source to disconnect. If I am in edit mode and I add a dimension or metric to a chart, for instance, it disconnects. There was one time where I tested making new custom metrics within a Google Sheet data source but I have completely deleted that data source already. I should probably mention that I can make style changes without the data source disconnecting, but any other edits basically break the dashboard.
If I am in View mode, the data source will disconnect if I change a date range or select something from a filter or sort a table by one of the columns...anything I touch basically causes a disconnect.
I finally opened a new browser window under a different username and created the exact same dashboards from the exact same data sources I was using in the problem account and everything seems to be working fine so far. For this reason, I think the problem is being caused by something at the account level or report level rather than by a specific data source or chart setting. I tried looking for the culprit by placing the reports from both accounts side by side and comparing every little setting I could find. I could not find any differences yet one account works fine while the other will basically not work at all.
I also tried posting images here to help illustrate but the system wouldn't let me.

Re: Data Sources in Data Studio Disconnect

Google Employee
# 4
Google Employee
Wow, that's really weird!

What browser and OS are you using?

And what exactly do you see when the data source "disconnects?"

(I've had trouble myself posting images to this forum, but I discovered if you edit the HTML source of your post and add a <p>foo</p> tag -- anything, really -- it seems to work.)

Re: Data Sources in Data Studio Disconnect

Explorer ✭ ✭ ✭
# 5
Explorer ✭ ✭ ✭
I'm using Chrome. I have not tried using other browsers with Data Studio
yet.
I've so far tried closing all windows, re-opening a new window and creating
a new dashboard from scratch but that did not work.
I then deleted all data sources and reports (even made sure to empty the
Trash section), closed/re-opened a new window, made a new report from
scratch and that did not work either. I also tried restarting my computer
with no luck.
I then tried opening a new window under a different username, connected the
exact same data sources, recreated the exact same report and it worked.
I then tried sharing the report made under the working account with the
problematic account, but the disconnection issue continued to persist under
the problematic account!
All of this seems to indicate that I must have done something within the
problematic account that is causing the issue, but I have no idea what that
could be.

...how I miss the days of fixing tech by banging stuff or blowing into
cartridges...

Re: Data Sources in Data Studio Disconnect

Google Employee
# 6
Google Employee
Yeah, kicking the Cloud is much less satisfying and not likely to accomplish anything ;-)

That is all very odd. I'm not sure what to suggest next. When you are saying "account," you mean your Google user account? As opposed to, say your Analytics account? Can you proceed using the account that works?

Re: Data Sources in Data Studio Disconnect

Explorer ✭ ✭ ✭
# 7
Explorer ✭ ✭ ✭
When referring to using a different "Account," I was actually referring to logging into data studio under a different email address in a separate window. It seems like everything is working now...not sure how or why.

Re: Data Sources in Data Studio Disconnect

Google Employee
# 8
Google Employee
I see. I wonder if there was a data source access issue with that account. For example, if you created the data source using one account and specified "Viewer's Credentials" in the permissions page. Then viewing a report built on that data source as the other user, who didn't have access to the data set.

I'm glad it's working now, though!

Re: Data Sources in Data Studio Disconnect

Visitor ✭ ✭ ✭
# 9
Visitor ✭ ✭ ✭

It's definitely not an unique issue, as I am banging my head over it for a few days now. The report was working fine at first, but now almost everyday it will show system error, whenever I change the date filter on the report. Sometimes the data is able to load, and the dashboard will continue to work until I change the date filter again. It seems like, anytime, datastudio needs to through a new query (I am using BQ as datasource), it will have issues. but if it's already in cache then will successfully render the dashboard. I also tried to create new calculated fields, and it will fail showing the following error: Unable to retrieve data.

 

issue1.pngissue2.png

Re: Data Sources in Data Studio Disconnect

Google Employee
# 10
Google Employee
Can you please submit feedback from the product next time this is reproduced (using the feedback icon or menu item).

Using the error codes displayed on screen, we can track down what is happening.

You may also click on the 'More' link of the error message and cut&paste what you see in here.