Data Studio
2.5K members online now
2.5K members online now
Ask questions about Data Studio
Guide Me
star_border
Reply

Calculated fields not showing up

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I created some calculated fields in my data source but they are not showing up in the metric picker.  Here are my calculated fields:

 

 calculated.PNG

But when I go to the Metric picker they are missing:

 

picker.PNG

Any idea why they are not there?

 

Thanks,

 

Scott

1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author Scott N
August

Re: Calculated fields not showing up

Participant ✭ ✭ ☆
# 5
Participant ✭ ✭ ☆

The main thing is to check that the chart is referring to the correct datasource. I find in my reports that when I have multiple data sources, sometimes my charts don't refer to the right one and I just need to flip them back.

Data source.JPG

View solution in original post

Calculated fields not showing up

Visitor ✭ ✭ ✭
# 2
Visitor ✭ ✭ ✭

So nobody has experienced this?  Is there some setting that needs to be done?  Very frustrating that there is no response.

Calculated fields not showing up

Participant ✭ ✭ ☆
# 3
Participant ✭ ✭ ☆

If you've created a new chart that you're trying to apply these metrics to, it's possible that DS defaulted to a different dataset and that's why your new metrics aren't showing up.  

Calculated fields not showing up

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

Actually, the charts already existed because I had to delete and recreate the data source.  Is that the problem?  And is there a way to fix this without deleting/recreating the charts?

 

Thanks for the reply.

Marked as Best Answer.
Solution
Accepted by topic author Scott N
August

Re: Calculated fields not showing up

Participant ✭ ✭ ☆
# 5
Participant ✭ ✭ ☆

The main thing is to check that the chart is referring to the correct datasource. I find in my reports that when I have multiple data sources, sometimes my charts don't refer to the right one and I just need to flip them back.

Data source.JPG

Calculated fields not showing up

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

You are right, there were two data sources with almost identical names, and I was using the wrong one.  Thanks for you help!