AdWords
1.8K members online now
1.8K members online now
Find out more about AdWords billing options, forms of payment, and promotional codes
Guide Me
star_border
Reply

I made payment for adwords but ad is not running

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I made payment for My google adwords account. It is showing my balance 500 Rs. But My Ad still not running and a message alert is generating ( Your account isn't active because you haven't entered your billing information.
To activate your account and start running your ads, enter your billing information). So what can be the reason that my ad is not running.

1 Expert replyverified_user

Re: I made payment for adwords but ad is not running

Top Contributor
# 2
Top Contributor
Hey Pradeep,

When you enter the billing information, AdWords will take 2-3 hrs to populate your billing information and that notification will be out.

So there is no need to worry and wait 2-3 hours, Your ads will be start appearing.
--Rakesh Kumar, AdWords Top Contributor , Twitter | Linkedin | Community Profile
Did you find any helpful responses or answers to your query ? If yes, please mark it as the ‘Best Answer’

Re: I made payment for adwords but ad is not running

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
I made payment yesterday. It has gone almost 20 hours. but still it is appearing this message. so what can be the other reason.

Re: I made payment for adwords but ad is not running

Top Contributor
# 4
Top Contributor
Hi Pradeep,

Yes if you have already wait for 20 hrs so you fill the below form to know the exact issues.

https://support.google.com/adwords/answer/8206?contact=1&rd=1#contact=1&ts=2839615

The AdWords team will help you on this and resolve your problems.
--Rakesh Kumar, AdWords Top Contributor , Twitter | Linkedin | Community Profile
Did you find any helpful responses or answers to your query ? If yes, please mark it as the ‘Best Answer’

I made payment for adwords but ad is not running

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

I have the same issue but it has been more than 24hours and still not working even though my balance shows