AdWords
3.5K members online now
3.5K members online now
Get started with AdWords - learn the basics to get set up for success
Guide Me
star_border
Reply

Site appears incorrectly in Display Network

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

As a publisher, I discovered a strange problem with my site's appearance in the Display Network.

 

I have a site let's say mydomain.com with AdSense ads and I sometimes go to Display Planner and type in my own domain and check how my inventory looks like. As far as I understand, this is what advertisers see when they want to place ads on my site.

 

Recently, I created another site under domain special.mydomain.com, it's a separate product, slightly related to the original, but separate, also with AdSense. So I go to Display Planner and type mydomain.com as usual, and then in the "Individual Targeting ideas" -> "Placements" I can see the website mydomain.com. But when I click on it, the screenshot is from special.mydomain.com and also the link below the screenshot leads to special. The Topics on the other hand look like a mix of both sites. So, an advertiser who wants to place ads will see the wrong screenshot and incorrect topics. He will be disoriented.

 

Next, I add the mydomain.com (from the list) to my plan to see what happens. Then go to review my Plan and click on mydomain.com to see the details. This time I can see correct screenshot and correct Topics in the details.

 

What to do with it? Because I think that if an advertiser wants to place an ad on my site, he will be disoriented by the screenshot with a different product and Topics list which he will see if he goes to the details screen, and perhaps won't place the ads at all.

1 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by MosheTLV (Top Contributor)
September 2015

Re: Site appears incorrectly in Display Network

Top Contributor
# 2
Top Contributor
Hi Beata P,

This isn't really the right forum for your question. You might get a better answer from the AdSense forum.

You say your main site is at mydomain.com. Is there no www.mydomain.com? Are the two sites possibly sharing the same IP address? That's fairly common if you're using something like CPanel to set up your sites. That could be confusing the issue.

When you go to mydomain.com (no sub-domain), do you see the right pages? If you go to www.mydomain.com do you see the same pages?

That's all I have for you,

Best of Luck!

Pete
petebardo -- Deadhead doing AdWords

View solution in original post

Marked as Best Answer.
Solution
Accepted by MosheTLV (Top Contributor)
September 2015

Re: Site appears incorrectly in Display Network

Top Contributor
# 2
Top Contributor
Hi Beata P,

This isn't really the right forum for your question. You might get a better answer from the AdSense forum.

You say your main site is at mydomain.com. Is there no www.mydomain.com? Are the two sites possibly sharing the same IP address? That's fairly common if you're using something like CPanel to set up your sites. That could be confusing the issue.

When you go to mydomain.com (no sub-domain), do you see the right pages? If you go to www.mydomain.com do you see the same pages?

That's all I have for you,

Best of Luck!

Pete
petebardo -- Deadhead doing AdWords

Re: Site appears incorrectly in Display Network

[ Edited ]
Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

I already asked this question in AdSense forums today and I was directed to this AdWords forum.

I have a redirection on the server on both domains from the www to non-www, so even when somebody types www.mydomain.com he is redirected to mydomain.com. And if somebody types www.special.mydomain.com, he is redirected to special.mydomain.com. It shouldn't be an issue.

Both sites are on the same IP address, because they are hosted on the same server. But of course in the browser typing each domain goes to the right page. The problem is only in the Display Network.

Do you know where else I could ask for help with this problem?

Re: Site appears incorrectly in Display Network

Top Contributor
# 4
Top Contributor
Hi Beata P,

Just a thought, have you added URL channels to AdSense or custom channels for each of the web sites.

Sorry I wasn't more help.

Pete
petebardo -- Deadhead doing AdWords

Re: Site appears incorrectly in Display Network

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
Hi Pete, I've talked to support and they told me that in such situation Display Planner will show only the domain and not the subdomain and it will generally treat the two as one for planning, that's what I understood. It seems strange to me that there are no separate subdomains in DP. Adding custom channels for targeting might work but I'll rather move the site to a separate domain because it is a new site. Thanks for your help.