AdWords is now Google Ads. Our new name reflects the full range of advertising options we offer across Search, Display, YouTube, and more. Learn more

Ads
4.7K members online now
4.7K members online now
Get started with Google Ads - learn the basics to get set up for success
Guide Me
star_border
Reply

Dynamic search ads - keyword doesn't currently trigger any of your ads

Badged Google Partner
# 1
Badged Google Partner

Hello,

 

I set up three of my campaigns to dynamic search ads. I set search ads targets - title + url - both are exact match with data on website. But statistics show nothing, not in a single ad group after 3 days. Even 0% web coverage. Diagnosis tool says my ads aren't showing, not sure where's the problem.

 

When I tried to be more generic, like adding only part of the phrase from URL or Title and only one parameter, it does something, not much from views or conversions, but at least it showed up some web coverage and landing websites example.

 

Please try to tell me what might be the problem? Is it SEO issue? I left bids exactly the same as they were in standard campaign, so bids or budget should be fine.

 

Any help will be more than welcome.

1 Expert replyverified_user

Re: Dynamic search ads - keyword doesn't currently trigger any of your

Rising Star
# 2
Rising Star
Hi Alex,

SEO matters are not related to Adwords campaign, Since you said you tried Keyword Diagnosis tool , usually you can see a reason mentioned there. Can you post a screen shot ?

Re: Dynamic search ads - keyword doesn't currently trigger any of your

[ Edited ]
Badged Google Partner
# 3
Badged Google Partner

Hello Nisal,

Screenshot wouldn't be that much help, because the message text is not in english.
But translation is like this: Are your ads showing? NO, This keywords is currently not triggering displaying your ad. This may have several causes.

Eventhough I'm searching for the exact phrase, that is on the site where I specified for google to search only. I mean if I set my ads for whole website I could imagine robots might have trouble finding the correct term, but if I specify the site for bots with URL and TITLE on very specific and unique web page, there shouldnť be problems like these. Not sure what's wrong.