AdWords is now Google Ads. Our new name reflects the full range of advertising options we offer across Search, Display, YouTube, and more. Learn more

Ads
1.8K members online now
1.8K members online now
Get started with Google Ads - learn the basics to get set up for success
Guide Me
star_border
Reply

Adwords refuses my url and I do not understand why

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭
1 Expert replyverified_user
1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author cortney k
November 2016

Adwords refuses my url and I do not understand why

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

No I found the problem and it took me ages the header locale is not sent when google analyses and I had a problem server side that just assumed the header was present. Thanks a lot though

View solution in original post

Adwords refuses my url and I do not understand why

Top Contributor
# 2
Top Contributor

Hey Cortney,

 

Please check the following to see if it may be causing the issue: 

 

#1 Is the domain of the Final URL matching the domain of your display URL? 

#2 Is your final URL display in your ads (the URL shown is your display URL)?

#3 Are you using a Final URL instead of a Destination URL (although this shouldn't necessarily make your destination invalid). 

#4 Is your URL redirecting to another domain or URL? Does it automatically initiate a download just by visiting the URL? 

 

If none of these are the reason please take a look at the following article to QA your problem: https://support.google.com/adwordspolicy/answer/6368661?hl=en 

 

Additionally you can also petition Google if your ad has been disapproved via the following link: https://support.google.com/adwords/contact/approval_request 

 

Let me know if this solves your problem! 

 - Josh

Joshua, Top Contributor
Was my response helpful? If yes, please mark it as the ‘Best Answer.’
Marked as Best Answer.
Solution
Accepted by topic author cortney k
November 2016

Adwords refuses my url and I do not understand why

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

No I found the problem and it took me ages the header locale is not sent when google analyses and I had a problem server side that just assumed the header was present. Thanks a lot though