My Business
3.4K members online now
3.4K members online now
Follow threads that discuss the latest tips on how to get your business online… for free!
Guide Me
star_border
Reply

Google API not displaying Address properly

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi There,

 

My GMB for Tarzana, Ca is displayed on Google+ Local perfectly. However, the Google API for this address is displaying as Los Angeles, Ca. Screenshot: https://docs.google.com/a/einsteinmedical.com/uc?id=0BzgDfNGh0E6ONG9zbUxaTm1TZzg

 

This has been causing inconsistencies in any network I sync my Google+ local page. I have contacted Google support multiple times and have been given the run around. 

One even asked me to find a bill that proves Tarzana, Ca is my USPS address.

 

Please let me know how I can get this corrected.

2 Expert replyverified_user

Re: Google API not displaying Address properly

Top Contributor
# 2
Top Contributor

Hi @Michael V

 

I'm trying to find you at that address on Map Maker to check something. But I don't see you.

What's the practice name for that location?  And how many locations do you have?

Re: Google API not displaying Address properly

Google Employee
# 3
Google Employee

Hi @Michael V,

 

Your issue seems to be with Google Maps Geocoding API, which is separate from the Google My Business API and has a Support Options for Google Maps Geocoding API page for your technical questions. Therefore, I’m moving this topic to the Basics for Business Owners board for you to report your business information discrepancies.

 

Thanks,

Terry

Google API not displaying Address properly

[ Edited ]
Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

Hi @Linda Buquet

 

Michael Vermesh, MD is the practice name for this location: https://plus.google.com/102232993132079340753

 

The address shows up as Tarzana on the Google+ Local. It is just when I connect with MOZ that it sends the information as Los Angeles.

 

 

@Terry W 

 

I have no clue what is Google Maps Geocoding API, I barley just learned about API. I posted to this page because this is where I was directed. I would not know the first thing about this. 

I just need to know the steps I need to take to fix this error. It should not be sending information as Los Angeles when I sync it to outside applications. Especially, when it shows correct on the page: https://docs.google.com/a/einsteinmedical.com/uc?id=0BzgDfNGh0E6OYkh5RWsyZkR2Y3c

 

Please clarify what steps I need to take to fix this. 

 

Google API not displaying Address properly

Top Contributor
# 5
Top Contributor

Hi @Michael V, so sorry for the delay getting back with you!

 

I was going to agree this is nothing to do with the API BUT then I re-read your 1st post and you said: "However, the Google API for this address is displaying as Los Angeles". 

 

So I'm confused. Where did that 1st screenshot come from?  The API?  How did you get the image if you are not using the API.

 

I found you on both maps and Map Maker and as you said the city is correct there, which is good news.

 

So I'm still confused. If it shows up right on GMB why did you call GMB support?  "It is just when I connect with MOZ that it sends the information as Los Angeles." 

 

We can't help with MOZ and I'm not familiar with the process there. So I guess you are maybe saying MOZ pulls from the GMB API and in that the API city is wrong? So then when MOZ propagates your info out you will have NAP inconsistency because the city will be wrong?

 

Please clarify or confirm I'm finally understanding. I've never heard of this problem so would need to escalate to Google, but want to be sure the issue will be clear to them before I do.

 

 

Google API not displaying Address properly

[ Edited ]
Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

 @Linda Buquet

 

Yes, when MOZ pulls from the GMB API and in that the API city is wrong and hen when MOZ propagates your info out you will have NAP inconsistency because the city will be wrong. 


I have talked with Moz and there is nothing they can do to change the information that they are receiving from Google.

 

I am honestly at a loss.

 

Google API not displaying Address properly

Top Contributor
# 7
Top Contributor

Hi Michael,

 

I'm at a loss too. I'm going to escalate to Google to find out how to fix this.

 

Please be patient as my Google contacts are very busy & don't work weekends.

If you don't get a reply by EOD Wednesday please remind me you still need help.

Google API not displaying Address properly

[ Edited ]
Top Contributor
# 8
Top Contributor

Hi Michael,

 

Just wanted to let you know I successfully escalated this. But it needs to pass through a couple departments in order to figure out the best option to correct it.

 

Please let me know if you notice it's fixed and I'll let you know when I hear something on my end.

Re: Google API not displaying Address properly

Top Contributor
# 9
Top Contributor

Hi Michael,

 

Sorry for the delay.  I heard back from Google and they said the problem lies with the Places API not the GMB API.  They gave me this support page:  https://developers.google.com/places/support

 

I'd found that info before BUT, all API support I can find is for companies like Moz that use the API for their services. There is no way I can find for an actual business owner who's data is wrong, to report it or get help.

 

The support all appears to be available only to the company using/offering the feed.  So I think you need to give that link to Moz to try to get it fixed. 

 

Sorry for the round robin. I know Moz said they could not fix it. They CAN'T on their end, but I think they are the only ones that can get to Places API support to get it corrected.

Re: Google API not displaying Address properly

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭

I have submitted this issue here. Let me know if you have any future suggestions, thank you for your help

https://code.google.com/p/gmaps-api-issues/issues/detail?id=10739&thanks=10739&ts=1477072253