AdWords
4.9K members online now
4.9K members online now
Dive into advanced features like Remarketing, Flexible Bid Strategies, AdWords Editor, and AdWords Scripts
Guide Me
star_border
Reply

ecomm_prodid not matching, but they look correct

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi

 

I am getting an issue with the ecomm_prodid not matching. Although, when I validate the remarketing take using the tag assistant, the value for ecomm_prodid is the same as the product id in my Merchant feed. So to me, it all looks correct. This is the full notification I receive:

 

Custom parameter "ecomm_prodid" and Merchant Center feed values don't match
Values for "ecomm_prodid" should match item identifiers in your Merchant Center feed.
The value of the "ecomm_prodid" parameter being passed to the remarketing tag is incorrect. Your tag's "ecomm_prodid" value needs to match either the "id" or "item_group_id" of the product in the connected Google Merchant Center account. Learn more
View tag implementation instructions
Top 10 products that don't match your Merchant Center feed

I have looked at these top 10 items and they do in fact appear to be correct. 

 

I am using Virtuemart, Rupostel OPC for my checkout as well as the data layer, and GBase XML for the feed.

 

My feed url is 

https://www.oscarjuicers.co.za/index.php?option=com_googlebasexml&format=xml&id=1

 

Any help would be much appreciated. 

 

Re: ecomm_prodid not matching, but they look correct

Visitor ✭ ✭ ✭
# 2
Visitor ✭ ✭ ✭

Hello Dylan,

 

Did you manage to fix this issue? I am having the same. 

 

YS

ecomm_prodid not matching, but they look correct

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

The same here!

ecomm_prodid not matching, but they look correct

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

No. Not having much luck. Been working on it for 2 months now.

ecomm_prodid not matching, but they look correct

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

What CMS and ecommerce software are you using?

Re: ecomm_prodid not matching, but they look correct

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

I'm using Shopify. I even got a Google engineer on the phone who helped me sort it out and confirmed it works but in the end it still doesn't work....

ecomm_prodid not matching, but they look correct

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭

Jumpseller.com