AdWords
5.3K members online now
5.3K members online now
Dive into advanced features like Remarketing, Flexible Bid Strategies, AdWords Editor, and AdWords Scripts
Guide Me
star_border
Reply

Not seeing sitelink extensions in Ad Preview and Diagnosis

Explorer ✭ ☆ ☆
# 1
Explorer ✭ ☆ ☆

For the last couple of days, when I try to view some of my ads in the Ad Preview & Diagnosis tool, it is showing up without its sitelink extensions.

 

However, when I look at the stats for the site links I am seeing lots of impressions (nearly as many as the total impressions for the ad). Furthermore, if I go into Google in another browser and run a search as a customer might, I do see my ad with sitelink extensions. Is this a known bug?

1 Expert replyverified_user

Re: Not seeing sitelink extensions in Ad Preview and Diagnosis

Follower ✭ ✭ ✭
# 2
Follower ✭ ✭ ✭
Hi Fnippy,

This is not a bug. Google doesn't display ad extensions all the time and for all targets. It may decide to display the extension on based of many parameters. Using ad diagnosis tools and doing a live search may be considered as searches with different parameter.

Re: Not seeing sitelink extensions in Ad Preview and Diagnosis

Explorer ✭ ☆ ☆
# 3
Explorer ✭ ☆ ☆
Thank you for taking the time to respond. I have never had trouble viewing my sitelink extensions in Ad Preveiw before. My reports show that they are running nearly every time my ad is shown. It is curious that they would suddenly stop appearing for me, don't you think?

I take it that everyone else is seeing their sitelink extensions properly in Ad Preview, so I will chalk this up to yet another unreplicable problem on my part. lucky me.

Re: Not seeing sitelink extensions in Ad Preview and Diagnosis

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭
This is also happening to me. And as in your case, started a few days ago. Before, I could also see the sitelinks in the ad preview. I suspect it is some update.

Re: Not seeing sitelink extensions in Ad Preview and Diagnosis

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
Samesies

Re: Not seeing sitelink extensions in Ad Preview and Diagnosis

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭
Hi Fnippy,

Are you logged into your account while previewing by any chance? I've had this problem too, I've tried all ways to get extensions to show, and it isn't just limited to my own ads (a search for big brand names leads to no extensions either). However I recently tried the same thing after logging out of my account and all extensions are working fine, log back in and they disappear. It's strange and it must relate to a bug somewhere. Hope this helps.

Re: Not seeing sitelink extensions in Ad Preview and Diagnosis

Explorer ✭ ☆ ☆
# 7
Explorer ✭ ☆ ☆

Yes, I was logged in when I tried it. I just logged out, went to the Ad Preview tool and checked one of my keywords. Lo and behold, there were the missing sitelink extensions. I knew they were running based on the reports I was getting, but it's nice to be able to see how they look on the screen and adjust the text if necessary.

 

Thanks for the tip. I hope they fix this bug. It was never a problem to be logged in before.

Re: Not seeing sitelink extensions in Ad Preview and Diagnosis

Visitor ✭ ✭ ✭
# 8
Visitor ✭ ✭ ✭
Google confirmed to me that that Ad preview currently does not show extensions.

Re: Not seeing sitelink extensions in Ad Preview and Diagnosis

Rising Star
# 9
Rising Star
Thanks for the info guys! I am sure I have a few finicky colleagues who must be going crazy over this.

Cheers!

Shashank
Cheers,
Shashank Singh, AdWords Rising Star |
Did you find any helpful responses or answers to your query? If yes, please hit "Like" or "Accept as Solution"

Re: Not seeing sitelink extensions in Ad Preview and Diagnosis

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭
Is there any way to tell if one has a misprint in the url? Is there any way to test a sitelink at all? Or do we just enter them with a keyboard and pray that we got it right?