AdWords
5.1K members online now
5.1K members online now
Dive into advanced features like Remarketing, Flexible Bid Strategies, AdWords Editor, and AdWords Scripts
Guide Me
star_border
Reply

BUG: Final url with parameters + tracking url - double question marks

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I have an ad with the final url: 

 

http://mysite.com/items?category=shoes

 

With the category parameter necessary to display the correct landing page.

 

And I have a tracking url set up with the following format:

{lpurl}?utm_source=google&utm_medium=cpc

 

When I click "test url" in the adwords interface it says "landing page found" and sets the "&" and "?" parameters correctly.

 

For instance, when I click "test url" it shows:

 

http://mysite.com/items?category=shoes&utm_source=google&utm_medium=cpc

 

However when the ad actually serves it resolves to this:

 

http://mysite.com/items?category=shoes?utm_source=google&utm_medium=cpc

 

with 2 question marks in the parameters.

 

This is causing errors for my urls and causes the ads to not be served.  What is the proper way to handle this? 

 

Thanks!

1 Expert replyverified_user

Re: BUG: Final url with parameters + tracking url - double question ma

Community Manager
# 2
Community Manager
Hi Joseph,

In the final URL you have already specified a ?

http://mysite.com/items?category=shoes

That would mean that the tracking template should look like this:

{lpurl}&utm_source=google&utm_medium=cpc (rather than {lpurl}?utm_source=google&utm_medium=cpc)

Can you remove the first question mark? You might want to contact the AdWords team with your issue, and account specific details.

You can find your local contact details here: https://support.google.com/adwords/editor/contact/awe_gen

Kathleen

Re: BUG: Final url with parameters + tracking url - double question ma

[ Edited ]
Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hey Kathleen,

Thanks for the response!

This suggestion causes an error if the tracking template is at a level other than the "ad level" (ie keyword level, ad group level, campaign level, account level).

Ie, if I change the tracking template to the one you suggested at the lets say, campaign level, then if any of my ads' landing pages do not contain a ? then it will cause an error.

Example:

Campaign Template: {lpurl}&utm_source=google&utm_medium=cpc

Ad 1 landing page: http://mysite.com/items?category=shoes
Ad 2 landing page: http://mysite.com

Ad 2 currently resolves to: http://mysite.com&utm_source=google&utm_medium=cpc

which is an invalid url and will return a 404. (since it does not contain a '?' before the parameters).

 

Is there a reason why Adwords just does not "url safe" the final combination of a final url & tracking template? 

 

Also, btw, in the Adwords editor, when I click "test url" for this set up, it does indeed properly convert the first '&' to a '?' when it shows the actual "Click Url" (thus converts it to a proper url).  However, when somebody actually clicks on the ad in an actual search result, it does not, and links to the invalid version of the url.  Any reason why these two URLs do not match?

Re: BUG: Final url with parameters + tracking url - double question ma

Community Manager
# 4
Community Manager
Hi Joseph,
I'm going to have a member of the AdWords team look into this for you. Please look out for an email from them.

Kathleen

Re: BUG: Final url with parameters + tracking url - double question ma

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
Thanks Kathleen, I will keep a lookout for their email.

Re: BUG: Final url with parameters + tracking url - double question ma

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

Hello

I am thinking that many of us are having this exact problem. Could we have the solution posted in this thread as well?

 

Thanks Jesper

Re: BUG: Final url with parameters + tracking url - double question ma

Explorer ✭ ☆ ☆
# 7
Explorer ✭ ☆ ☆
Dear Joseph,

You cant have two ? in a single url , with {lpurl}?utm_source=google&utm_medium=cpc, your landing page will have two '?' so your tracking parameter wont work.

to counter this you have to use tracking parameter at ad level.

Re: BUG: Final url with parameters + tracking url - double question ma

Visitor ✭ ✭ ✭
# 8
Visitor ✭ ✭ ✭

Well, yes that is a doable workaround. However, this kind of goes against the whole concept of upgraded urls. One of the great upsides of “tracking template” was the ability to centralize and simplify tagging. However, when the Adwords engine just concatenate the url parts in such a simple and rather unsafe manner, it renders the upside unusable. I am back to ad-local checking and tagging.

Re: BUG: Final url with parameters + tracking url - double question ma

[ Edited ]
Visitor ✭ ✭ ✭
# 9
Visitor ✭ ✭ ✭

^^ Exactly, if I have some landing pages in an ad group that require a parameter (ie www.mydomain.com?page=2) and some that don't (ie www.mydomain.com), I would not be able to set a tracking template at the ad group (or keyword or campaign or account) level. I would have to set them at the ad level.

Also, in the adwords UI, when you click "check url" it actually does concatenate multiple "?" in the url correctly when it shows you a preview of the click url, even when using "two" ? marks, (one in the final url & one in the adgroup tracking template).

So at the very least they should change that as it is quite misleading.

Re: BUG: Final url with parameters + tracking url - double question ma

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭
EDIT: Looks like they fixed the bug in the UI...it now will show the double "?" marks in the preview of the click url instead of properly formatting it.