AdWords
2.1K members online now
2.1K members online now
Dive into advanced features like Remarketing, Flexible Bid Strategies, AdWords Editor, and AdWords Scripts
Guide Me
star_border
Reply

Adwords Social Extension Approved, But Now Showing in Ads

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I have my Google+ Company Page linked to my Adwords Account and Approved. We have more than +270. So we have met all the requirements for this to appear in Adwords, but our Google+ followers information is not showing up in our Adwords Ads Smiley Sad

 

1 Expert replyverified_user

Re: Adwords Social Extension Approved, But Now Showing in Ads

Top Contributor
# 2
Top Contributor

Hello,

 

Fulfilling the eligibility is fine, but I think it's not that always you can see your Social extensions with your ad. 

 

Did you actually check the segment +1 annotations to see if it's actually working or not. 

 

Also, you need to make sure you are adhering to advertising policies related to social interaction, standard advertising. I would encourage you to read this help center reference for more details: https://support.google.com/adwords/answer/1722132?hl=en

 

Pankaj

Re: Adwords Social Extension Approved, But Now Showing in Ads

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
I'm testing my Ads on the Adwords Ad Preview Page https://adwords.google.com/d/AdPreview
And none of them are showing up with the Social Extension...
I checked the +1 annotations and there is no data

Re: Adwords Social Extension Approved, But Now Showing in Ads

[ Edited ]
Follower ✭ ✭ ☆
# 4
Follower ✭ ✭ ☆

Hi Eugenio,

Sometimes it has to do with the Quality Score of your keywords. Is it high? Have you tried to see if one adgroup with keywords of quality score 10/10 is showing its ads with social extension?

Re: Adwords Social Extension Approved, But Now Showing in Ads

[ Edited ]
Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

One of my adgroup has keywords from 6/10 to 10/10 quality score and the Google Plus info is not showing, y have segmented my campaign using the "+1 Anotations" and there is no data there so it is not working