AdWords
2.8K members online now
2.8K members online now
Use AdWords conversion tracking and reporting to measure your results. Have a question about Google Analytics? Post it here, on the Google Analytics Community!
Guide Me
star_border
Reply

Some Adwords Adgroups not displaying in Google analytics

Follower ✭ ✭ ☆
# 1
Follower ✭ ✭ ☆

Hi There,

 

We're running a campaign that contains 7 ad groups but despite all ad groups receiving clicks, only one ad group's clicks are showing up in Google Analytics (after 3 days).

 

All ads are using the same campaign settings so I'm not sure if links are not being tagged by Adwords?

 

Just not sure how to trouble shoot this issue sorry - any help would be much appreciated

 

Cheers

 

Ben

1 ACCEPTED SOLUTION

Accepted Solutions
Marked as Best Answer.
Solution
Accepted by topic author CMSCSS
September 2015

Re: Some Adwords Adgroups not displaying in Google analytics

Explorer ✭ ☆ ☆
# 2
Explorer ✭ ☆ ☆

HI CMSCSS,

 

Welcome to the AdWords community.

 

We had a similar issue in the past with one of our accounts. You may want to try removing the code and re-adding it. It also may be a tagging issue on your site. Such as "arbitrary URL parameters", if your webmast currently doesn't allow this it may track some of the ad groups but not all which was the case for our client. This article, specifically the Special Case section at the bottom will serve as a good resource: http://support.google.com/analytics/bin/answer.py?hl=en&answer=1033981

 

The only other thing I would suggest is to give Google a call. The link below will give you their support number. Just use the drop down to choose the country you are in. http://support.google.com/adwords/answer/1385067?hl=en

 

I hope this was helpful.

 

Best,

 

Stefan Martinez

Best,

Stefan Martinez
-- Not an AdWords expert, just a student eager to learn more...

View solution in original post

Marked as Best Answer.
Solution
Accepted by topic author CMSCSS
September 2015

Re: Some Adwords Adgroups not displaying in Google analytics

Explorer ✭ ☆ ☆
# 2
Explorer ✭ ☆ ☆

HI CMSCSS,

 

Welcome to the AdWords community.

 

We had a similar issue in the past with one of our accounts. You may want to try removing the code and re-adding it. It also may be a tagging issue on your site. Such as "arbitrary URL parameters", if your webmast currently doesn't allow this it may track some of the ad groups but not all which was the case for our client. This article, specifically the Special Case section at the bottom will serve as a good resource: http://support.google.com/analytics/bin/answer.py?hl=en&answer=1033981

 

The only other thing I would suggest is to give Google a call. The link below will give you their support number. Just use the drop down to choose the country you are in. http://support.google.com/adwords/answer/1385067?hl=en

 

I hope this was helpful.

 

Best,

 

Stefan Martinez

Best,

Stefan Martinez
-- Not an AdWords expert, just a student eager to learn more...

Re: Some Adwords Adgroups not displaying in Google analytics

Follower ✭ ✭ ☆
# 3
Follower ✭ ✭ ☆
Thanks heaps for the reply - when you say "Removing code and re-adding it" do you mean the GA code?

Re: Some Adwords Adgroups not displaying in Google analytics

[ Edited ]
Follower ✭ ✭ ☆
# 4
Follower ✭ ✭ ☆

Great suggestion to call support!

Turned out that the initial autocomplete where Google puts the display URL into the destination URL was at the start of the ad URL - effectively making the URL go to a page that didn't exist.

Always tripple check the URLs on your ads before going live!

 

Cheers