AdWords
5.5K members online now
5.5K members online now
Use AdWords conversion tracking and reporting to measure your results. Have a question about Google Analytics? Post it here, on the Google Analytics Community!
Guide Me
star_border
Reply

Question mark in upgraded URLs

Follower ✭ ☆ ☆
# 1
Follower ✭ ☆ ☆

Hi there

I have a question regarding upgraded URLs. It seems like using upgraded URLs, will add a question mark (?) to the address as a part of URLs.

 

In our website, all the languages by default have an “?” in their URLs (Except English) and due to some technical stuff, having two questions marks in the URL causes problems. 

 

This is an example of our link when we apply upgraded URL:

https://www.sample.com/?l=ID?adwordscampaignid=27058&adwordskeyword=binary

 

as mentioned before, having two questions marks in URL causes problems. For example, the link redirects people to the wrong languages etc.

 

Is there anyway to fix this? I mean is there a way to use upgraded URLs without adding an question mark to our link?

 

 

 

Re: Question mark in upgraded URLs

Explorer ✭ ✭ ✭
# 2
Explorer ✭ ✭ ✭

Hey Nariman, 

 

In the tracking template column, try with this template.

 

{lpurl}&adwordscampaignid=27058&adwordskeyword=binary

 

Hope this can solve the problem.

 

Cheers!

Shafi Ahamed

 

 

Re: Question mark in upgraded URLs

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Hi Shafi,

What if some of my final URLs have question marks, some do not? for the URLs that do not have question marks, the tracking template would break the landing page as I would end up with something like:

https://www.sample.com/&adwordscampaignid=27058&adwordskeyword=binary

Thanks

Re: Question mark in upgraded URLs

[ Edited ]
Follower ✭ ☆ ☆
# 4
Follower ✭ ☆ ☆

Thanks @shafi for your reply. As i mentioned, my URL already has a "?" by default, and as you may know, google also automatically adds an extra "?" to the link which this is the cause of problem where based on our DNS setting, two question marks will send people to wrong page, and changing these setting will cost us technical etc, so we prefer not to change the setting and see whether there is another way to solve the issue.