AdWords
4.9K members online now
4.9K members online now
Use AdWords conversion tracking and reporting to measure your results. Have a question about Google Analytics? Post it here, on the Google Analytics Community!
Guide Me
star_border
Reply

Missing Google gclid

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hello Support,

 

We are experiencing issues with gclid not passing for certain visitors (40% or so).

 

Example:

Visitor A coming from site A via Google AdWords example.com has gclid, and Visitor B coming from Site A via Google Adwords example.com doesn't have gclid but the previous visitor did.

 

We are currently seeing 40% of our traffic NOT containing the gclid but are passing c, ag, ad, and placement but missing gclid parameter.

 

Looking forward to hearing from you Smiley Happy

1 Expert replyverified_user

Re: Missing Google gclid

Top Contributor
# 2
Top Contributor

Hi Hani,

 

Are you sure that the auto tagging feature inside your account is enabled? Secondly also ensure that the gclid parameter is supported by your website. For example: Google will append the link like this: www.mysite.com/?gclid=123xyz.

 

So you and your web administrator has to ensure that the same link opens up confirming that auto tagging works.

 

On the contrary if it doesn't work, you will have to manually tag the URLs to see the report in Google Analytics. See this for more details:- https://support.google.com/analytics/answer/1033867?hl=en

 

Pankaj

Re: Missing Google gclid

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Pankaj,

Auto-tagging is enabled, and it's not a web issue as you can see the example above that 2 users came from the same source site let's say yahoo.com one containing the gclid and the other visitor didn't.

It's strange that it's happening to some users but not others.

Re: Missing Google gclid

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭

Bump, We really need to figure this error out Smiley Happy

Re: Missing Google gclid

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

I am experiencing this issue as well.

Missing Google gclid

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭

We're experiencing the same issue. Auto-tagging is on, but there are no GCLID in the urls. We're using the following custom tracking templates on the campaign level: {lpurl}?source=google&medium=cpc&campaignid={campaignid}&adgroupid={adgroupid}&term={keyword}&h1={_h1}