AdWords
2.9K members online now
2.9K members online now
Use AdWords conversion tracking and reporting to measure your results. Have a question about Google Analytics? Post it here, on the Google Analytics Community!
Guide Me
star_border
Reply

Error in Google Tag Assist

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I have just tried to implement the Dynamic remarketing tag and verify the code with Google Tag Assist.  The following error is being thrown:

 

Tag Paramater object could not be parsed

 

Anyone know what could be wrong? My development URL is:

http://dev14-puritan-nbty.demandware.net/s/vitaminworld_us/home?icid=ros-_-header-_-logo

 

I've read up on every article I could find. I've gone through all of the common syntax mistakes ... any help would be greatly appreciated.

Re: Error in Google Tag Assist

Explorer ✭ ✭ ☆
# 2
Explorer ✭ ✭ ☆
Hi,

The product IDs are numeric in the site but the object for home contains quotes, usually only for non-numeric product IDs.

Have you considered removing the quotes entirely for the home?

Ali

Re: Error in Google Tag Assist

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Hi Ali,

I was placing single ticks around the prodId and the pageType then leaving
the total value numeric.

I was using the following instructions as a guide:
https://support.google.com/adwords/answer/3103357?hl=en&authuser=2

So for example if I do a view page source on my homepage I will see:




But the tag manager assist says: "Tag Paramater object could not be parsed."

Re: Error in Google Tag Assist

Explorer ✭ ✭ ☆
# 4
Explorer ✭ ✭ ☆
In this case it seems you're missing a quotation mark for prodid on home.

"" rather than '' should be used, I believe

Ali

Re: Error in Google Tag Assist

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
Ali,

Even if I remove my code and just hard code the line to:
ecomm_prodid : ""
I still get the error

--Kristina

Re: Error in Google Tag Assist

Explorer ✭ ✭ ☆
# 6
Explorer ✭ ✭ ☆
Kristina, hi!

While we wait for more input from other contributors I'm going to try replicate on a site I run and see if I can replicate this error somehow.

In the meantime, do you want to address the non-standard implementation warning?

Ali

Re: Error in Google Tag Assist

Explorer ✭ ✭ ☆
# 7
Explorer ✭ ✭ ☆
Other sites seem to have bypassed the error entirely by leaving out the value and setting 0 as the product ID, maintaining home as the page type

Re: Error in Google Tag Assist

Visitor ✭ ✭ ✭
# 8
Visitor ✭ ✭ ✭
Ali,

Just for more information this is a code snip of what I have:
var google_tag_params = {
ecomm_prodid: ${(typeof(pids) != "undefined" && pids != null && pids.length > 0) ? pids : ""},
ecomm_pagetype: '${(typeof(googlePageType) != "undefined" && googlePageType != null && googlePageType.length > 0) ? googlePageType : "other"}',
ecomm_totalvalue: ${(typeof(googlePrices) != "undefined" && googlePrices != null && googlePrices.length > 0) ? googlePrices : ""}
};

I didn't see a non-standard implementation warning!

Re: Error in Google Tag Assist

Explorer ✭ ✭ ☆
# 9
Explorer ✭ ✭ ☆
I meant to be more specific - sorry!

Code should be placed directly above the closing <body> tag.

Could you try the snippet you have without value (just for the home page) and with productid=0 just to see if that resolves things?

Ali

Re: Error in Google Tag Assist

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭
I've just tried to set the prodid = to 0 or to "0" and I got the error on both tries.
As for moving the tag - it is as close to the close body tag as I can get it the way the site is built - I'm using a cloud base platform called Demandware