AdWords
1.5K members online now
1.5K members online now
Use AdWords conversion tracking and reporting to measure your results. Have a question about Google Analytics? Post it here, on the Google Analytics Community!
Guide Me
star_border
Reply

Cannot See Google Adwords traffic in Analytics after linking in my MCC

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I am operating a Google MCC account where i have linked an adword account & an analytics account from two different email. After successful linking, i am still unable to see Google Adwords paid traffic in Analytics. 

adwords.pngGoogle Adwords & Analytics

 

You can see in the screenshot above, the paid traffic clicks, yet there are no sessions, and other attributes. Any one has a solution for this?

2 Expert replyverified_user

Re: Cannot See Google Adwords traffic in Analytics after linking in my MCC

[ Edited ]
Top Contributor
# 2
Top Contributor

Hi Aditya,

You must have missed a step in your linking process (maybe check that autotagging is enabled). Please review the steps here: https://support.google.com/adwords/answer/1704341?hl=en


-Tommy

 

Edit - here is some info on auto-tagging too - https://support.google.com/adwords/answer/3095550?hl=en

Tommy Sands, AdWords Top Contributor | Community Profile | Twitter | Philly Marketing Labs
Did you find any helpful responses or answers to your query? If yes, please mark it as the ‘Best Answer.’

Re: Cannot See Google Adwords traffic in Analytics after linking in my MCC

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Hi Tommy,

I have auto-tagging on. Could there be any other reason?

- Aditya

Re: Cannot See Google Adwords traffic in Analytics after linking in my MCC

Top Contributor
# 4
Top Contributor
Totally agreed with Tommy, rectify this auto-tagging your will surely get all the data though not instantly.

Regards
Archit, AdWords Top Contributor, Community Profile
Did you find any helpful responses or answers to your query ? If yes, please mark it as the ‘Best Answer.’

Re: Cannot See Google Adwords traffic in Analytics after linking in my MCC

Collaborator ✭ ☆ ☆
# 5
Collaborator ✭ ☆ ☆
Hi
This most probably looks like a filter issue to me. Can you please check filters on the GA view which you are referring to?
Is there a filter which is filtering out the either adwords sessions or the part of website where users are landing?
Regards, Nik
LinkedIn  |   @nikhilparachure | My Blog

Re: Cannot See Google Adwords traffic in Analytics after linking in my MCC

Visitor ✭ ✭ ✭
# 6
Visitor ✭ ✭ ✭
Hi Nikhil,

I have no special filters on. And at the moment, the landing page is the homepage itself.

Regards, Aditya

Re: Cannot See Google Adwords traffic in Analytics after linking in my MCC

Top Contributor
# 7
Top Contributor
Hi Aditya,

Please try 1 more thing, hopefully it will help you.
go to your adwords account >> settings(gear icon) >> linked accounts >> Google analytics >> edit the linked account >> Import site metrics >> save.
Please wait for some time, hope your issue will be solved.

Note: please ensure auto-tagging is enabled from GA account.

Regards
Archit, AdWords Top Contributor, Community Profile
Did you find any helpful responses or answers to your query ? If yes, please mark it as the ‘Best Answer.’

Re: Cannot See Google Adwords traffic in Analytics after linking in my MCC

Visitor ✭ ✭ ✭
# 8
Visitor ✭ ✭ ✭
Hi Nikhil,

I have been through this process. The Google Analytics is picking up organic traffic but the Google adwords traffic is missing.

Regards, Aditya

Re: Cannot See Google Adwords traffic in Analytics after linking in my MCC

Collaborator ✭ ☆ ☆
# 9
Collaborator ✭ ☆ ☆
Can you click on one of your ads and make query string GCLID is being passed in landing page URL?
Regards, Nik
LinkedIn  |   @nikhilparachure | My Blog

Re: Cannot See Google Adwords traffic in Analytics after linking in my MCC

[ Edited ]
Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭
@theniks wrote:
Can you click on one of your ads and make query string GCLID is being passed in landing page URL?

 

Hmm, no. Why isn't it showing up? I linked the accounts properly. Do i have to switch to manual tagging?