AdWords
3.5K members online now
For issues or questions regarding logging in, account access, or account security
Guide Me
star_border
Reply

Unable To Begin Adwords Fundamentals Exam

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hello! Recently, I've been attempting to take the fundamentals exam, but I've been running into a problem. Whenever I try to do so, I get the same error message, before I can even attempt to start the exam. It tells me: "Request could not be completed. Please try again." That's all I see. Seeing as the timer never even begins, it seems I can't even get that far.

 

To give a timeline of these issues . . . I've been trying to take the test for about a week, and having the same result. My normal browser is Opera, but I switched to Chrome when I started having trouble with this. Nevertheless, the problems have continued. I checked to see if Chrome was updated to its current version, (it was), and cleared the cache before trying again. This also seems to fail. I have tried it from both my laptop and my desktop, (connected to the same computer network) with the same result.

 

Looking for answers seems to show people who have had trouble continuing the exam, but no one seems to have had trouble getting it to start. Is this a new problem, or a known one? Is this local to my machines or network, or is it part of a problem that is broader than my ability to fix?

1 Expert replyverified_user

Unable To Begin Adwords Fundamentals Exam

Top Contributor
# 2
Top Contributor

Try in chrome incognito mode.  (All extensions are disabled)

Moshe, AdWords Top Contributor , Twitter | Linkedin | Community Profile | Ad-Globe
Did you find any helpful responses or answers to your query? If yes, please mark it as the ‘Best Answer’