AdWords
5.8K members online now
For issues or questions regarding logging in, account access, or account security
Guide Me
star_border
Reply

Sitelinks not showing - general support copy paste answer from google

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

We are having a problem with site links.

To explain the general build, We have 4 site links on an AdGroup, apart from this we also have call outs as well, they are rarely showing either but not to the same extent.

In the example we have a QS of 10, CTR of around 50%, avg pos is 1 and in the last 20 days we had around 5k clicks.

Now, no mather were we google from (proxy, device, at home, at the office, at an internet cafe) we cant get the site links to show. We have asked A lot of people to search and print screen and the results are the same for EVERYONE, NO site links are showing.

Contacted Google support, and as usual get the canvas reply that this is working as intended and it's actually showing, yadda yadda. They said they contacted SME and that they cant find any problems, of course there is the usual link to a support article. https://support.google.com/adwords/answer/1704420?hl=en

Now we are running out of options, does anyone know of a way to troubleshoot this that is not in the usual help articles?

1 Expert replyverified_user

Sitelinks not showing - general support copy paste answer from google

Top Contributor
# 2
Top Contributor

Do sitelinks direct to the same landing page?

Moshe, AdWords Top Contributor , Twitter | Linkedin | Community Profile | Ad-Globe
Did you find any helpful responses or answers to your query? If yes, please mark it as the ‘Best Answer’

Sitelinks not showing - general support copy paste answer from google

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭

Hi MosheTLV,

 

They all direct to different landing pages.

Sitelinks not showing - general support copy paste answer from google

Top Contributor
# 4
Top Contributor

Try to remove  and to recreate them.

Moshe, AdWords Top Contributor , Twitter | Linkedin | Community Profile | Ad-Globe
Did you find any helpful responses or answers to your query? If yes, please mark it as the ‘Best Answer’

Sitelinks not showing - general support copy paste answer from google

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭

Have now removed them all and created new ones, let's see what happens. Feels like I just tried to restart my computer as a solution Smiley Happy

Sitelinks not showing - general support copy paste answer from google

Top Contributor
# 6
Top Contributor

Interesting case. Please update once you have results.

Moshe, AdWords Top Contributor , Twitter | Linkedin | Community Profile | Ad-Globe
Did you find any helpful responses or answers to your query? If yes, please mark it as the ‘Best Answer’

Sitelinks not showing - general support copy paste answer from google

Visitor ✭ ✭ ✭
# 7
Visitor ✭ ✭ ✭

So, we did remove and upload again, only thing changing was the trailing slash, so before the final url was www.xyz.com and now www.xyz.com/

 

Didn't make a difference, however we did notice something today and that is that it's ONLY showing for mobile device (the little imps it has). Like literately, desktop/tablet is not even showing in the segment report.

 

Checked all device settings and it is really set to show on ALL devices everywhere (my ego would had taken a serious hit if that was not the case Smiley Tongue ).

 

Mailed the lovely google support again with this finding and waiting for a reply (wonder what suggestion they will take from cases this time).

 

Problem still exists however. 

Sitelinks not showing - general support copy paste answer from google

Top Contributor
# 8
Top Contributor

Using the ad preview tool - are you seeing the sitelinks?

Moshe, AdWords Top Contributor , Twitter | Linkedin | Community Profile | Ad-Globe
Did you find any helpful responses or answers to your query? If yes, please mark it as the ‘Best Answer’

Sitelinks not showing - general support copy paste answer from google

Visitor ✭ ✭ ✭
# 9
Visitor ✭ ✭ ✭

On mobile yes, desktop no. We also tried with proxies, clean browsers etc etc

Sitelinks not showing - general support copy paste answer from google

Visitor ✭ ✭ ✭
# 10
Visitor ✭ ✭ ✭

As an update to this: We did solve it, not with the help of Google I might add since everything was fine from their perspective.

 

We were using tracking links in the tracking templates which all lead to different pages on the site. However in the Final Url it was all www.xyz.com (to avoid any compliance issues with final needing to be less or same than tracking url, the end url from the tracking usually changes lp over time so it's really hard to have specifics there). 

 

When removing the tracking template and setting the final url to different lp:s it started serving.