AdWords
2.8K members online now
For issues or questions regarding logging in, account access, or account security
Guide Me
star_border
Reply

Cannot accept invitation to AdWords

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

I was sent an invitation to have access to an existing AdWords account and when I enter in the email address and password, it gives me this error message: "You're currently logged into your organizational account at .... To access your existing AdWords account, please use the login ....com@gtempaccount.com and the same password" and I cannot login. This account is not associated with another AdWords account. I've tried logging in directly to AdWords and get the same message. I've cleared the cache, tried different browsers and different computers and I keep getting the same message. I really don't want to create a new account since this one is already setup with an Analytics account and I want to be able to access everything from one login... Is there anything that can be done to gain access? Any advice or info is appreciated.

 

 

Re: Cannot accept invitation to AdWords

Participant ✭ ✭ ✭
# 2
Participant ✭ ✭ ✭
Hi,

It seems that for some reason is identifying that you must log in with the temporary account (e.g @gtempaccount e-mails).

You should try to log out from all google accounts you have and try to access again with the desired account. Try to use a new browser instance, you can create a new browser user in chrome as if it was from scratch or even try and use incognito mode to try and log in for the first time. This usually solve the problems.

Does this account have only one e-mail access? Anyone else have access to it? If it does, you can ask for the person to remove your access and invite you again.

Hope this helps.

Leandro Martinez | Basta1Click

Re: Cannot accept invitation to AdWords

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Thanks for the advice. I tried all of the above and had anyone in the office with access to the account log out. I cleared the cache again, used an incognito window, and still the same thing. I'll probably give them a call and see if they can help resolve the issue. Thanks again for the response