AdWords
2.7K members online now
For issues or questions regarding logging in, account access, or account security
Guide Me
star_border
Reply

AdsCommon::Errors::Error Environment 'PRODUCTION' does not support version 'v201609'

[ Edited ]
Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Here are the steps I followed.

Installed latest version of google adwords api gem(using a ruby gem).

Google ads common gem is using 0.12.5 version which is also updated one.

In one of the docs on github it is mentioned if ruby version is lower than 2.2.2 then run gem install rack -v 1.6.4.

All this was done and tested on development environment also when deployed to staging I had no issue with the environment.

I was able to refresh the token and use the authentication hash to create google adwords api and create audiences.

When deployed to production. I get this
AdsCommon::Errors::Error Environment 'PRODUCTION' does not support version 'v201609 - which is the latest version.

Kindly help me understand what is the issue here and how do I resolve this

1 Expert replyverified_user

AdsCommon::Errors::Error Environment 'PRODUCTION' does not support version 'v201609'

Community Manager
# 2
Community Manager

Hi Manjusha,

 

If you're having trouble getting the AdWords API set up, I would recommend posting directly to the AdWords API forum. They'll be able to help you more quickly with a specific question like this.

 

Cassie