AdWords
4.6K members online now
4.6K members online now
Understand Google's advertising policies, including ad approval status and account suspension
Guide Me
star_border
Reply

Destination URL Not Working

Visitor ✭ ✭ ✭
# 1
Visitor ✭ ✭ ✭

Hi,

 

I having a strange situation occur where I am getting ads disapproved with the reason reported as "Destination URL Not Working". When I click through on the ads the page loads fine, and quickly.

 

I've looked through our web server logs and all traffic to the pages in question have had the proper HTTP response, including any traffic from Google's ad bots.

 

I'm at a loss as to what to check next. Is there any way to get a more detailed technical reason other than just "Destination URL Not Working"?

 

Thanks,

 

Phil

1 Expert replyverified_user

Re: Destination URL Not Working

Top Contributor
# 2
Top Contributor

Hi Phil,

 

Destination URLs are gone now. It's the Final URLs. Are there any redirects in between when the user clicks the ad and reached the final URL? Also make sure that you have done the heat checks as mentioned in below screenshots:-

 

Destination.png

 

Also have you tried contacting AdWords support on this issue, if everything looks fine, but the ads are getting disapproved? https://support.google.com/adwords/answer/8206?hl=en&hlrm=en

 

Pankaj

Re: Destination URL Not Working

Visitor ✭ ✭ ✭
# 3
Visitor ✭ ✭ ✭
Hi Pankaj, and thanks for the reply.

We are using Final URL in the ads but the disapproval reason is still listed as Destination URL Not Working. I have been through all the checks listed above and have reached out to Google for further feedback.

I'm just wondering if other people here have had a similar experience and if so what their issue was.

Thanks,

Phil

Re: Destination URL Not Working

Visitor ✭ ✭ ✭
# 4
Visitor ✭ ✭ ✭
We are having a similar situation. Did you ever end up getting this figured out?

Re: Destination URL Not Working

Visitor ✭ ✭ ✭
# 5
Visitor ✭ ✭ ✭
We never got a firm answer but we changed the structure of our account and the problem went away.

Previously we had one campaign per "product" for each user country being targeted. This meant the same final URL appeared in ads in multiple campaigns. We moved to a structure where we targeted all the countries in one campaign so the final URL only appears once in the account, and the problem has gone away.

My suspicion is that it was a internal issue in Google with trying to hit the same URL multiple times in a short space of time. We never saw any errors in our server logs for the URLs in question.